View Full Version : How to add new units into your MTW game?

02-08-2009, 04:35
I want to learn how to add new units into my MTW game. (I am using MTW Vikng 2.01)

Who can teach me?THKS

02-09-2009, 11:10
Well, you've come to the right place (almost). ~:joker:
What got me into modding was adding simple, basic units into the game - and then it just went crazy from there, but I must say that to mod MTW, you've got to be patient, have plenty of time on your hands, and be able to tolerate getting frustrated at your computer... and did I mention patient?

To start, I highly recommend reading one of the following guides:
Either This Guide (http://www.gamefaqs.com/computer/doswin/file/539605/31131) at GameFAQs.
Or This Guide (https://forums.totalwar.org/vb/showpost.php?p=484300&postcount=4) here at the .org.

Once you've got the hang of that you may want to try some of the other guides here in The Repository (https://forums.totalwar.org/vb/forumdisplay.php?f=39).

If you have any troubles just post here (in this thread) or create a new thread in The Alchemist Lab (https://forums.totalwar.org/vb/forumdisplay.php?f=18), and either I or any other fellow modder will be glad to help (I think...).

02-10-2009, 14:55
Thks a lot,I see that it's a complex work............headach

02-26-2009, 07:19
Now,I tried to add an unit into my XL-MOD game. When I come into the game,I find that it can be found in the trianing menue,but the result goes to Ottoman infantry,my god!! So,I decided to play the custom battle..........On the battle field,but I can see only legs on the horse (the uint is Polish kinghts),without head,hand and body...not like human being......

WHO can help me ?THKS

02-26-2009, 09:21
The maximum number of units in a unit_prod.txt is 256. The XL mod has more than 256 and any extra units you put on the end show up but cannot be built. You can add agents and ships past the 256 limit but any soldiers you add aren't going to work.

You will have to overwrite (or replace) one of the other units to be able to recruit your new troops.

As for the graphics, you might've made a mistake somewhere when you were in the folder "Textures" - make sure the new unit has a proper text file in the "ActionsPage" folder.

Again, any questions, just ask.

02-27-2009, 01:56
Yesterday I made advance work,then I can see the knight's horse,weapon,and shield.
But,the problem is that there is nobody on the horse.............why??

02-28-2009, 10:33
Now I find that the most key is this :the unit use FullPlAr as its shape you see "FULLPLAR, YES, YES, LiHorse".
But I can't overwrite the folder "FullPlAr" in "Total War\Textures\Men\FullPlAr" for that many footknights use this shape ,too!
Then I tried to rename the uint's name of its shape such as "FullPlAr1". But I can's go into the game for the shape can't be recognized.
So,who can teach me how to process?

03-05-2009, 11:11
Capital letters make no difference in how the game finds each folder, just as long as the letters are all there it'll work. Which folders you can use are hard-coded, what's there is there. You cannot create new folders in the Textures\Men\ folder.

You've also got something wrong with the way you've implemented the unit in unit_pod.txt.
FullPlAr is only foot knights (there are NO mounted units). Your new unit is mounted on a horse, yes? Well you'll need a different texture than what you have (change FullPlAr in unit_prod.txt to something else, e.g. MKnight).