View Full Version : How to: Anti-Aliasing in Shogun 2 without a patch

03-25-2011, 21:15
Tired of the jaggies? Want to enable AA? You're in luck! CA was telling the truth when they said the engine has full support of anti-aliasing, they just haven't allowed you to enable it in game yet. However, there's a work around for you folks who simply cannot stand the little jagged edges on things. The answer? Forcing it through your video card settings. I found this short guide on the internet, followed it and it worked for me. If it works for you, feel free to report back here.

For ATI cards

Go to “start” menu and search CCC (Windows 7 users only) then you can find gaming tab, and what you need to do now is to click 3D application settings, next in the AA option uncheck use in game settings and put it to what ever you want. Thats how you do it.

note from Monk: CCC is catalyst control center. Another good place to look is in the bottem right hand partion of the screen. Catalyst usually installs a quick-launch icon in the tray there.

For Nvidia cards

Right click the desktop, click the nvidea control panel, in 3d settings, click on manage 3d settings. Then click on program settings tab, then find shogun 2 total war. After that you will see a list of options underneath it, click ‘anti aliasing setting’ and set it to whatever you want, e.g 2x, 4x etc.

Have fun!

03-25-2011, 21:17
Yes, I do remember that setting now that you mention it.

Thanks for sharing this Monk. :bow:

03-25-2011, 21:23
Yes, I do remember that setting now that you mention it.

Thanks for sharing this Monk. :bow:

Since the patch for AA might not hit until a month or more from now, i figured it'd be good to spread the love. Hope it helps :bow:

03-25-2011, 21:54
I wonder how I missed that trick from Starcraft II experience.

Thanks for the reminder, Monk. ^^

03-25-2011, 22:24
Weird side effects here.

Set to 4X: The game runs without any problems. I enter a battle, look around, unconvined, quit, but hey ! 5 FPS when back to main menu ? The stuttering is permament. I quit the game.

Set to 8x: The game runs fine until the battlefield is loaded. I can only see the Start Battle gong, nothing else other than the play/pause panel, 5 FPS again. I somehow manage to start the battle, the battlefield and soldiers appear at last. But the stuttering is enormous (5 FPS). I quit the battle, still the same at the main menu and then quit the game.

Catalyst 11.2 here, anybody else having such problems with enforced AA ? (mine is Edge-detect AA, btw)

03-25-2011, 22:40
I have an nvidia card and did 2x, battles looked much better and no side-effects that I could see. :shrug: