PDA

View Full Version : How to host shogun MP Games.



Shambles
05-29-2005, 04:42
Shogun MP Game Hosting. :help: :book:

Ok 1st things 1st
We need to get you on to fakeserver.

I host one, And so does tosa,
Now there are a couple of ways to get yourself on to the fake server,
i will tell you the 1 that needs least amount of editing on your part 1st,

you can Download Shamblestw.exe
http://shoguntw.2ya.com/ShamblesTW.exe
that will allow you to switch between servers, with relitive ease.

If you cant run BAT files please install
Libary files
http://www.ascentive.com/support/new/libraryfiles.exe
I previously added a link to this file that was then replaced with a virus,
But this 1's good


Now most people that are left in the MP shogun community use Warlord edition v1.02

so you probably need to download the official v1.02 patch

This is WE v1.02 UK/US
http://download.activision.com/activision/totalwar/shogunpatch/ShogunWv1.02_Euro.exe

This is JAPANESE v1.02 Gold edition
http://download.activision.com/activision/totalwar/shogunpatch/ShogunGv1.02_Jap.exe

This is asian v1.02 WE
http://download.activision.com/activision/totalwar/shogunpatch/ShogunWv1.02_Asia.exe

For other updates visit
http://www.totalwar.com/community/download.htm

Then u can also download Toga's Stats swapper,
So you can switch between game versions
I.e Back to v1.0
This will only work with v1.02
http://snow.prohosting.com/tdrabags/Statswapper.exe


An Alternative way of connecting to fake server is you can edit your internet.cfg file, (so no need to download shamblesTW.exe)

so edit the text in the internet.cfg file located in your shogun game folder
like so

For tosa's server



ChatserverIPAddress = 212.238.194.39
ChatserverPort = 8793
NewsserverIPAddress = daphne.eagames.co.uk
NewsserverPort = 8797
ShogunTotalWarWebsite = www.totalwar.com

or for mine



ChatserverIPAddress = ShogunTW.no-ip.info
ChatserverPort = 8793
NewsserverIPAddress = daphne.eagames.co.uk
NewsserverPort = 8797
ShogunTotalWarWebsite = www.totalwar.com

Then when your In the game
Hit multiplayer
then tick use existing Internet connection

next simply click on Play on EaPlay

It will attempt to connect,
it may take several attempts but will eventualy connect.

Then you are on The fakeserver and able to play multiplayer games and join other peoples hosted games !!!!



As for hosting your own games
SEE POST NUMBER 4

ShambleS
:bow:

Drisos
05-30-2005, 09:22
Thanks for the clear information, shambles. I hope I can fix it soon. ~:)

Shambles
05-30-2005, 13:15
Please feel free to state The way you connect to the interenet.
Any devices you use to conect to the internet,
Manufacturers namee and Model of your components,

I.e
you are conected to a pc with a wierless network, Through a router. And that pc connects to the internet.


What is a router?

Well heres a picture or 2 of what they COULD look like

*pic removed*-Sasaki
They should not be confused with modems

For details on hosting behind a router.
SEE POST NUMBER 4

"THE NEXT POST"

ShambleS
:bow:

Shambles
06-04-2005, 14:31
Here I adress 2 factors,
1, the fact that It is difficult to log in to fakeserver to play your online games,
And
2, When you host a game people cannot see them.
So please bear with me and read the "article" throughly


Heres the "article"
------------------------------------------
These are the same basic directions You would use to Allow your self to Host any game,
but You would need to know which ports that particular game uses,


These are 2 ports that shogun uses,

8793
AND
18321

It use them For hosting games, and receving UDP's That allow you to see other hosted games,

these 2 ports are always used, So you can open them but id advize you only leave them open for Shogun.

However fake server is begining to puzzle me,
it accepts incoming ports from almost any range,
and every time some 1 logs in the port number changes,

I.e
I log in to fake server and it registers,

My-ip.adress:1200

then trish would log in.
and it would register,

Trish-ip.adress:1201
then some 1 els would log in
and it would use,

There-ip.adress:1202
And so on.

So there is No 1 port number i can give out that will guarantee you a place on fake server,
Infact,

If i told people to open port
1205
This would not neciseraly guarantee that you could connect as that port may not be the one shogun has now decided to use.

But also, Fakeserver dosent always let people log on 1st attempt,
even if shogun is attempting to connect on an unused and open port,

So unfortunatly The only thing i can tell people to do Is just try again untill it does eventualy log on,

Some times it will be 1st time,

for most it will be some where between 1 in 3 and 1 in 7 attempts will connect,

Others may find it even more difficult.

As for hosting games behind a router,
It seems even with the correct ports open.
People cannot host a game sucsessfuly,

This is becous your router conects to the interenet and you then connect to it,

So people only see your routers ip adress and not Your pc's ip adress

I.e
you router registers you on to the internet. and its Ip adress is,
11.11.111.111
and your real ip adress for your pc is
11.22.121.221

The game then registers you on to fakeserver as,
11.11.111.111
When it should register you as
11.22.121.221
So people then cannot see your game,

Heres the deal in more precice detail

When you host a game, other joining players need to be able to connect to your Pc, but when the incoming connection request reaches your router, your router does not know which pc it should forward the request to, so instead it just ignores the request. This is what is happening when other players are unable to join your hosted games.

But dont worry You can Fix this,

The solution is to configure your router to do port forwarding/port mapping. This tells the router to forward requests from certain games directly to your pc's local/private IP address

You should check The documents that came with your router.
As this would tell you how to set up port forwarding correctly for your device,

Your device will be difrent from the next persons device,
so I cant really tell you how to set up yours, But your documentation can.

However, If you dont know where your documentation is.

I can send you to this web page which will help you set up port forwarding,
This Is how you would configure any Game. so people can see your Hosted games,

Remember,
here we are trying to allow SHOGUN to forward the ports, 8793 and 18321, To YOUR pc's local address. "dont say allow all programs to forward to these ports as that could compromize your system security"

this page will dislpay your local adress, and help you configure a multitude of Firewalls and routers to forward the ports needed from your router to your pc,

http://portforward.com/routers.htm

This is the only way people behind a router can host games, and allow people to see them,

Im sorry about the fake server login problem's But really There is nothing we can do about it,
The thing is just Annoying,

P.s
You could tell your router to forward ALL ports that shogun tries to send or receve data on, (port 1 to port 9999) or port range 1-9999

(DO NOT tell it to allow ALL programs to forward ports as this could also comprimise your computers security, But allowing SHOGUN To forward things would Just allow Shogun to do so And there for is safe to do.)

This would guarantee shogun game hosting capabilaties to you,
and could help you log on to fake server slightly faster

"but fake server will still probably take multiple log in attempts to connect"


Thank you for your time,
and I hope this helps you host your online games "not only shogun"

ShambleS
:bow:



EDIT
this is a link to SpeedTouch. 580 wireless router configuration details,
http://www.adslguide.org.uk/hardware/reviews/2005/q2/speedtouch580.asp

Cha
06-12-2005, 12:11
Here I adress 2 factors,
1, the fact that It is difficult to log in to fakeserver to play your online games,
And
2, When you host a game people cannot see them.
So please bear with me and read the "article" throughly


Heres the "article"
------------------------------------------
These are the same basic directions You would use to Allow your self to Host any game,
but You would need to know which ports that particular game uses,


These are 2 ports that shogun uses,

8793
AND
18321

It use them For hosting games, and receving UDP's That allow you to see other hosted games,

these 2 ports are always used, So you can open them but id advize you only leave them open for Shogun.

However fake server is begining to puzzle me,
it accepts incoming ports from almost any range,
and every time some 1 logs in the port number changes,

I.e
I log in to fake server and it registers,

My-ip.adress:1200

then trish would log in.
and it would register,

Trish-ip.adress:1201
then some 1 els would log in
and it would use,

There-ip.adress:1202
And so on.

So there is No 1 port number i can give out that will guarantee you a place on fake server,
Infact,

If i told people to open port
1205
This would not neciseraly guarantee that you could connect as that port may not be the one shogun has now decided to use.

But also, Fakeserver dosent always let people log on 1st attempt,
even if shogun is attempting to connect on an unused and open port,

So unfortunatly The only thing i can tell people to do Is just try again untill it does eventualy log on,

Some times it will be 1st time,

for most it will be some where between 1 in 3 and 1 in 7 attempts will connect,

Others may find it even more difficult.

As for hosting games behind a router,
It seems even with the correct ports open.
People cannot host a game sucsessfuly,

This is becous your router conects to the interenet and you then connect to it,

So people only see your routers ip adress and not Your pc's ip adress

I.e
you router registers you on to the internet. and its Ip adress is,
11.11.111.111
and your real ip adress for your pc is
11.22.121.221

The game then registers you on to fakeserver as,
11.11.111.111
When it should register you as
11.22.121.221
So people then cannot see your game,

Heres the deal in more precice detail

When you host a game, other joining players need to be able to connect to your Pc, but when the incoming connection request reaches your router, your router does not know which pc it should forward the request to, so instead it just ignores the request. This is what is happening when other players are unable to join your hosted games.

But dont worry You can Fix this,

The solution is to configure your router to do port forwarding/port mapping. This tells the router to forward requests from certain games directly to your pc's local/private IP address

You should check The documents that came with your router.
As this would tell you how to set up port forwarding correctly for your device,

Your device will be difrent from the next persons device,
so I cant really tell you how to set up yours, But your documentation can.

However, If you dont know where your documentation is.

I can send you to this web page which will help you set up port forwarding,
This Is how you would configure any Game. so people can see your Hosted games,

Remember,
here we are trying to allow SHOGUN to forward the ports, 8793 and 18321, To YOUR pc's local address. "dont say allow all programs to forward to these ports as that could compromize your system security"

this page will dislpay your local adress, and help you configure a multitude of Firewalls and routers to forward the ports needed from your router to your pc,

http://portforward.com/routers.htm

This is the only way people behind a router can host games, and allow people to see them,

Im sorry about the fake server login problem's But really There is nothing we can do about it,
The thing is just Annoying,

P.s
You could tell your router to forward ALL ports that shogun tries to send or receve data on, (port 1 to port 9999) or port range 1-9999

(DO NOT tell it to allow ALL programs to forward ports as this could also comprimise your computers security, But allowing SHOGUN To forward things would Just allow Shogun to do so And there for is safe to do.)

This would guarantee shogun game hosting capabilaties to you,
and could help you log on to fake server slightly faster

"but fake server will still probably take multiple log in attempts to connect"


Thank you for your time,
and I hope this helps you host your online games "not only shogun"

ShambleS
:bow:



EDIT
this is a link to SpeedTouch. 580 wireless router configuration details,
http://www.adslguide.org.uk/hardware/reviews/2005/q2/speedtouch580.asp
Should I type in both 8793 and 18321 at the internet file?

Shambles
06-19-2005, 16:02
Should I type in both 8793 and 18321 at the internet file?

no they are ports that your pc uses to send data,
Most people wont have a problem, But if you use a router then you may haft to adjust some settings,
Some firewalls may also need to be edited to allow incoming connections, on certain ports.

each process that uses the internet on your pc is allocated a port number,
If these ports arent open then the data cant be receved or sent,

So those ports are the 1s that people must open and then forward to their pc, from their router,

R'as al Ghul
06-19-2005, 16:28
UDP or TCP?
Thats the question.
both TCP doesnt seem to work, neither does both UDP.
~:confused:

Shambles
06-19-2005, 17:35
i give them udp and tcp.
udp are usualy what let people see your hosted games,
and then it also uses tcp as a nother chanel for data,
Most games use udp for the most part and tcp for a kind of back up

Shogun seems to use tcp most but you need udp to let people see your hosted games,
so both tcp and udp are needed.

heres how i have my shogun setup on my fire wall,

Note that the ports and stuff are only open to Shogun
the same ports can be opend for 1 game alone on routers as well,

I use udp and tcp protocalls and Any other stuff it may need,

And the ports are opend for both local and internet use

http://freespace.virgin.net/shambles.instalations/settings.jpg

R'as al Ghul
06-20-2005, 16:57
okay, I've forwarded the ports 8793 & 18321. Both UDP and TCP.
However there're a few questions left.
My settings:

Protokoll Port to IP-Address to Port
UDP 8793 192.168.178.20 8793

The IP is my local machine. The setting looks similar in all 4 cases.
Notice the last column "to port". Is 8793 in this case correct?
Or should it be something different?

Another issue is UPnP. My router has it activated for
transmission of status-request (sorry, translation here).
Under WinXP I like to have it deactivated.
I guess I need to change that?

Anyone who can host and is behind
a router, can you please share your settings with us?

~:cheers:

Drisos
06-20-2005, 17:17
I have done about the same.

Entered 10.0.0.138 as my router IP-adress, and forwarded ports 8793 and 18321 both tcp and udp.

R'as checked for me but he couldn't see the game.

Shambles, what can it be?

:dizzy2:

darn router! :furious3:

Drisos
06-20-2005, 21:57
http://img22.echo.cx/img22/8012/router8rh.jpg

I the those ports. It should work now shouldn't it?

I only can't figure out how to let shogun only use them.

Hope it works.

P.S.: This thread should be stickyfied. :bow:

EDIT: thanks for the link in your post. That's my router. I now managed to open ports. ~:cool:

R'as al Ghul
06-21-2005, 19:59
Are you really sure about the port numbers, Shambles?
Where are they from?

I know for a fact that I've my router configured properly
and from the screenshot that drisos provided I can tell
that he's done the right thing too (that is if the IP-address
is correct).

You should also correct your post because you're
mixing up IP and port several times.
No offense but this topic really gets on my nerves. :furious3:

GAH!

R'as al Ghul
06-22-2005, 07:40
drisos,

we made a mistake in your settings.
It just occured to me. You're reaching your
router interface under 10.0.0.138. This also means that
your local machine has a different IP. This
other IP is the one that you need to enter for the
port-forwarding.
Because the router is already visible on the web.
What we want to "see" is your local machine.

But, I've got it correct and it still isn't working.
:wall:

R'as al Ghul
06-22-2005, 09:17
Desperate attempt to host #X:

Ok, here's what I did to ckeck my router's portforwarding.
There's this low budget game "Soldat". Google it, it's the first result.
The free 12MB download comes with a dedicated server exe and the game exe.
So I set up a dedicated server, forwarded the required udp port, called my brother
and told him to login. Worked immediatly.
This test proves that my portforwarding settings are ok.

Next thing I tried was running the Fakeserver for Shogun.
I set it up, fired up the game (after editing my own internet-IP into
Internet.cfg) and connected to my own fakeserver.
My Firewall then prompted me that the Fakeserver was
being contacted my a "remote machine" (that was me), I accepted
the incoming connection and was thereby connected to myself via
Internet. This proves that the portforwarding of 8793 works properly.

As far as I can see, my settings are correct. I suspect that Shogun uses
more than two ports. Medieval uses at least six.

Shambles has opened a whole range of 10.000 ports (or was it 1.000?).
This is something I can't do on my router. There's no possibility
to enter a port range. Every port has to be edited manually.
So, I'd really appreciate if someone could determine, perhaps checking his
firewall's log files, the correct ports.

And yes, I'll keep talking to myself here until I get answers.
:bow:

Drisos
06-22-2005, 12:01
This also means that
your local machine has a different IP.

OK. But how do I find out what IP adress my local machine has? :dizzy2:

R'as al Ghul
06-22-2005, 12:32
You have to run the program "Ipconfig".
Open the command line tool.
This has to be somewhere in your start menu.
If you don't find it, open the "Run"-menupoint
and type cmd into it. Hit return. A window with black
background should open, offering a commandline.
Enter "ipconfig" without "".
The first line in return shows your IP.
This IP needs to be entered instead of the one
already showing in the router interface screeny.

However there's one issue with this,
atm I've no idea if your machine keeps this
number or is assigned a different one by the router
every time (once per day). So this might work only
one time for you.
But I promise you drisos, as soon as I find it out,
I'll do everything to get your machine to do what
mine does.

~:cheers:

Drisos
06-22-2005, 12:37
But I promise you drisos, as soon as I find it out,
I'll do everything to get your machine to do what
mine does.

Thanks for all the help R'as! I really appriciate you taking the effort to help this tech-noob out. I hope we both solve the hosting problems. ~:)

:bow:

I'll try now. :book:

Drisos
06-22-2005, 14:11
I used 'run' from the start menu and typed 'ipconfig'

some screen appeared, with a black background and some text. Problem is, it disappears after less then a second and I can't read that fast.

Any other method? Or a way not to let the screen dissappear right away?

:dizzy2:

R'as al Ghul
06-22-2005, 14:16
You're almost there.
Use "run" again and type "cmd".
The black window opens and stays open.
Now enter "ipconfig".
When done hit the "X" of the window to close.
Entering "exit" may also work.
~:cheers:

Drisos
06-22-2005, 15:10
So:

1) enter "cmd" in "run"

what should happen then?

2) enter "ipconfig" in "run"

-when i enter after typing "cmd", there is a message 'the program (or some parts of it) could not be found. Check if the path is right and if the necessary library's are there'

-after that, instantly "ipconfig" appears in "run" but it still disappears when i run it

sorry for my lacking english. I got that message in dutch and couldn't translate it better. :dizzy2:

PaolinoPaperino
06-22-2005, 15:19
in that case search for the file:
cmd.exe
(between hidden files & system too) and launch it manually.

Drisos
06-22-2005, 15:36
Can't find it.

I entered "cmd" found other files with "cmd" in it's name.
I entered "cmd.exe" found nothing
I tried looking for .exe files with "cmd", found nothing

Beginning to think I don't have the file . . . :(

Are you sure I have that file?

Isn't there any other way? It still doesn't work... :dizzy2:

R'as al Ghul
06-22-2005, 15:53
drisos,

every Windows OS has the MS-DOS-Command line.
If your search for cmd.exe doesn't return anything it's not there.
It may be that you haven't installed it.
Please go to System Control Panel/Software/Windows-components

Each component has an additional detail tab. Open them all until you come
across the command line tool.

Once you have it installed, entering "cmd" in "Run.." opens a black window
that stays open. Here you enter the "ipconfig" command.

~:cheers:

Drisos
06-22-2005, 15:56
OK I'll try. ~:cheers:

Drisos
06-22-2005, 16:06
every Windows OS has the MS-DOS-Command line.
If your search for cmd.exe doesn't return anything it's not there.
It may be that you haven't installed it.
Please go to System Control Panel/Software/Windows-components
Each component has an additional detail tab. Open them all until you come
across the command line tool.
Once you have it installed, entering "cmd" in "Run.." opens a black window
that stays open. Here you enter the "ipconfig" command.

Windows OS? what means the OS actually

I couldn't find the 'command line tool' maybe if you tell me what it is I can translate into Dutch and find it in the System CP

Should I install it with my windows CD-rom? We lost it. :furious3: I do have a map called options/cabs in windows which contains all that was on the CD-rom, so I might be able to install it anyway.

:dizzy2: im puzzled!

R'as al Ghul
06-22-2005, 16:44
OS=Operating System

http://img62.echo.cx/img62/1754/unbenannt22dt.jpg
This is how the command-tool looks like.
The german word is "Eingabeaufforderung"
Notice the icon with the "C:\" prompt.
Look out for that.

R'as al Ghul
06-23-2005, 09:38
:bow:

I did some more testing and have the feeling that I'm very close.

When hosting a LAN game Shogun listens to UDP 2290.
When hosting a game on fakeserver it listens to TCP 2467.

And then there're also the ports for directplay
6515 (Dplay UDP)
6500 (Query Port)

I'll try to test those ports asap.

:bow:

Drisos
06-23-2005, 11:35
I found the program and entered ipconfig:

http://img156.echo.cx/img156/8272/ip2mf.jpg

But now? what is my IP?

Let's host.

Good luck and hope we solve it, R'as. ~:)

Shambles
06-23-2005, 16:00
Lots of posts here,

Ive been a lil busy so havent seen any of these earlier,

The port numbers i found in my firewall.
I checked the port numbers that shogun uses when conecting to games and crating hosted games,
also it connects to fakeserver through a port so that has been added to.

My firewall tells me that, shogun uses
port 1683
and
port 18321
It also connects to fakeserver on
port 8793,

aslong as you can forward the the datais to the right place those ports are what you need,

I.e

your real ip adress is,
123.456.789

and your router ip is 122.333.444

id expect it to be

inside adress 123.456.789:8793 outside adress 122.333.444:8793

inside adress 123.456.789:18321 outside adress 122.333.444:18321

R'as al Ghul
06-23-2005, 16:18
Anytime I host a game, doesn't matter if own fakeserver,
Shambles fake, or LAN my machine
listens to a random (so it seems) UDP port.
I've had several. In fact each time a different one.

I'd like to try to host a game, alt tab to my firewall,
check out which UDP it listens to, open that port,
alt tab back into lobby to check if people can see/join.

:bow:

Shambles
06-24-2005, 00:39
Yeah every time the game conects to a server I.e my fake server.
It uses a random port.

it will use 1 after another till it finds a working 1.

I.e
I try to connect to fake server.
Shogun uses port 1221
Connection fails.
So i try again,
Shogun will now try port 1222.
If it fails and i try again
shogun will use
1223
And so on untill connection works,

this is nothing to do with actualy hosting games though,
thats just the Game connecting to a server,
Routers dont seem to mind this at all, and let you conect to the server ok.

Its just that when you host a game.
Your router says to the server.
"IM HOSTING A GAME HERE & MY IP ADRESS IS (222.333.444)"
Thats not a big problem
apart from the fact that The Pc Hosting the game has an ip of 123.456.789

So the router shoule be saying

"IM HOSTING A GAME HERE & MY IP ADRESS IS (222.333.444) BUT SEND THE INFO ON TO IP (123.456.789)"

any ports should be added aswell.

I.e

Your router is ip 123.456.789
and shogun uses port
123


Your pc's real ip adress is 222.333.444

You need to tell your router to.

Forward Data receved on 123.456.789:123
to
Your pc's ip adress and port number. 222.333.444:123

Drisos
06-24-2005, 09:47
R'as, my routers IP is 10.0.0.138 right? I should include that as outside IP.

But I still don't know my computers IP? (inside IP)

I should open ports 8793 18321 both udp and tcp

:dizzy2:

R'as al Ghul
06-24-2005, 10:56
From the screenshot it looks like the local IP
is 10.0.0.1
Sorry that it took me awhile.
drisos, you won't have any luck with those two ports.
There're more needed. Until we know fo sure I'd suggest
you don't do anything.

Shambles,
there isn't a single new thing in your post
that you hadn't already posted.
Please take no offense but you do know
what the problem is, do you?

I don't care what random port is used to
connect to fakeserver.
The only thing that matters is the port being
used when hosting, and that seems to be random, too.

:bow:

Shambles
06-24-2005, 16:52
No matter how many times i host a game, And i can host games,
It uses the same port.

and thats
18321

I never tried playing on LAN,
Which is not the same as internet play any way and there for does not need port forwarding as you use local adresses to connect to the games,

But when playing Online. No matter HOW many times you host a game,
Shogun uses port 18321

Its just a matter of port forwarding,
Something that must be done to Most multy-player games if you want to host them,

I Know What i say is the same as Ive always said,
And the reason for that is,
Its the same question asked.

ports that are changing, are probably your shouguns connection to fake server,
if you can connect to fakeserver This is redundant and you can ignore shoguns systematic changes of ports,

but to HOST games, Shogun uses Port "18321"
It always uses that port,
Check this your self

Start shogun.
Enter mp foyer
host game
And proceed to faction select window,

Now go look at what port shogun is Listening for data on.
Its going to be
port 18321.

The problem is one that Many people haft to resolve,
Its a matter of telling your router to forward the data from the router to the pc,

The port that people need to see is 18321.
That port allows people to see the hosted game,
Its all the info i can give you really,


port 8793 is how shogun finds fakeserver,
It then connects using difrent ports.

Port 18321 is the port you host on.


And look here,
http://www.whatismyip.com/
Thats you Ip adress.

BTW
Have a look.


http://freespace.virgin.net/shambles.instalations/There1.jpg

R'as al Ghul
06-24-2005, 17:52
Start shogun.
Enter mp foyer
host game
And proceed to faction select window,

Now go look at what port shogun is Listening for data on.
Its going to be
port 18321.

Nope, nothing happens.
BTW, I've forwarded 18321 as have others and we still can't host.
What's your explanantion for this?
We haven't configured properly?

I still think you don't understand....

R'as al Ghul
06-24-2005, 17:59
http://img267.echo.cx/img267/9754/ports7dd.jpg

This is my firewall when I host a game on your fakeserver.
The only connection is a random port to your 8793.
The same as when I simply log in.

R'as al Ghul
06-24-2005, 18:03
When hosting on LAN:

http://img56.echo.cx/img56/6687/ports21np.jpg

Opinions?

R'as al Ghul
06-24-2005, 19:41
And finally when I'm hosting on my own fakeserver.
Isn't it peculiar that only when I'm hosting on LAN
the port 18321 is used?
http://img187.echo.cx/img187/1265/ports36vg.jpg
:wall:

Shambles
06-25-2005, 14:12
Nope, nothing happens.
BTW, I've forwarded 18321 as have others and we still can't host.
What's your explanantion for this?
We haven't configured properly?

I still think you don't understand....


I dont think You understand,
And thats why you cant host games.

Drisos
06-25-2005, 14:50
Shambles,
there isn't a single new thing in your post
that you hadn't already posted.
you don't know
what the problem is, do you?

Nope, nothing happens.
BTW, I've forwarded 18321 as have others and we still can't host.
What's your explanantion for this?
We haven't configured properly?

I still think you don't understand....


I dont think You understand,
And thats why you cant host games.

:stop:

No more of this please. We cannot afford fights in the small stw mp community.

I say: Ignore eachother about this point. R'as, start your own thread and don't post in this one anymore. Shambles, keep posting in this one and don't do so in the thread R'as will post. You two both post your own way of hosting games in stw mp and let the players decide which way they'll choose.

Remember that there are no winners in fights, only losers.

Hope the both of you fix it.

:bow:

R'as al Ghul
06-25-2005, 18:52
I dont think You understand,
And thats why you cant host games.

Fair enough. You return my insult. Okay
I provoked that and I'm not really mad because of it
but that the echo of my insult is the only thing
I hear from you is a bit disappointing.

You haven't adressed the problem at hand a single time.
Sure you've told us to open the ports 8793 and 18321.
But you fail to acknowledge that people still can't host
although they have opened the ports.
There's no use in telling me that I shall open the ports
when I've told you that they are already open.

And believe me I do understand. I can host MTW games.
I can host other games, filesharing works, I can seed with bittorrent,etc.
I do understand my firewall and my router perfectly.

My problem is that my game doesn't open a port when
I host online. It does open the port when I host on LAN though.
(Btw, ports are also used in LAN, contrary to what you've said above)
This is something that you probably can't solve but ignoring
my questions all the time and telling me I don't understand
instead of telling me that you don't know the answer is an insult.

Shambles
06-25-2005, 19:31
The game does use ports when in Lan And thats not what i said,
I said you use a local adress when playing on lan, So router wont affect it,

If the game does not attempt to open a port when you begin hosting games, that implies That its not the routers fault, and your game is not functioning properly,

Id love to tell you whats wrong with your game, But I dont suffer this problem,
So i cant really work on fixing it,

Some where along the line something is either blocking shogun from opening aditional ports. I.e Fire wall.
Windows fire wall Could be causing problems for some,

The most logical explanation Is,
fire wall settings are incorrect,
And not allowing shogun to open that port,
If the router forwards the port to the right Ip adress.
Then fire wall settings should be tested,

Personaly id find some 1 to come help me see if hosted games work without fire wall runing,
then systematicaly disable programs 1 by 1 untill i can host,

There could simply be an error some where in your game,
However i dont think that is the case.

I really think it could be a firewall problem, if the routers are fine, then it can only be a fire wall problem,

R'as al Ghul
06-26-2005, 08:27
If the game does not attempt to open a port when you begin hosting games, that implies That its not the routers fault, and your game is not functioning properly,
Ahh, now you're talking business. That's exactly what I've thought.



Id love to tell you whats wrong with your game, But I dont suffer this problem,
So i cant really work on fixing it,
I understand that perfectly. Nevertheless I appreciate that you took
the time to look into it.
I take it we have reestablished peace now?
I apologize for getting .... impatient and slightly mad.



Some where along the line something is either blocking shogun from opening aditional ports. I.e Fire wall.
Windows fire wall Could be causing problems for some,

It's really a dilemma.
I've XP firewall disabled.
Sygate firewall allows Shogun everything but I keep it running to monitor the connections. I had turned it off once to test with drisos.
Directplay test of Directx returned positive.
I've Upnp enabled.
My router forwards the posts - 100% positive here.

As Shambles said, it looks like my Shogun.exe is not working properly
because it doesn't listen to the host port 18321 when on WAN (only when on LAN).
I really would like to see the firewall-logs of others who can't host,
just to know if their games at least open the port.

~:cheers:

Shambles
06-27-2005, 09:42
Your shogun exe seems to be called shogunM.exe
and mine is called shogunW.exe

is this becous you have shogun MI and not WE?
The problem could be a MI problem i suppose,
I know that the origional shogun cant host games on Fakeserve,
But then again the origional shogun cant See games either.

I dont know what i can do to try and fix this problem, as i dont actualy own mongol invasion.
but i will see what I can find out,

Drisos
06-30-2005, 17:54
Hello guys,

turns out my ip is 84.84.240.28

I can't open a port range like shambles can either.

What to do with the 'default server ip'? I don't know what it is and don't understand the online info about it either. should I use my comp ip, my router ip, or a standard ip adress? (in that case, which?)

Here's the screen:

https://img140.imageshack.us/img140/7364/defaults0cl.jpg

*****

I entered my comp ip as outside adress and router ip as inside adress. Is that correct? It wouldn't work when I tried the opposite.

Here are my settings:

https://img88.imageshack.us/img88/2465/configuration7zv.jpg

You see that it's different then the first time I forwarded. The ip adresses see m to be ok as the tcp says 'listen' now and I guess it works then. upd still says 'none' but that might be ok coz upd is used to let others see the game and then my comp does nothing with them so it says 'none'.

Hope it'll work now. Shambles, you want to check for me tomorrow in the afternoon? And R'as, I'd be glad to try for you too.

:dizzy2:

~:cheers:

Kraellin
07-02-2005, 17:24
hi guys,

i've never used fakesrvr, but if it's a true server, then ALL the rules of servers apply just like they would on gamespy, or the EA servers or the Activision servers. generally, and this is very general, if you cant host but can connect to others, then you've got a firewall up somewhere that isnt allowing others to originate to you, or, your router is blocking on the necessary ports. that's the simplicity of it. USUALLY, it's a firewall, especially if you can connect to others.

if you cant connect to others or host, then it's a firewall/router OR a version mismatch.

for specific help on opening ports and firewalls, check the gamespy article on their web pages on this AND your firewall and router manuals/documentation.

one simple thing to try is to simply turn the firewall off and try again. this is ok if you have a router up also. it already has a firewall built into it. dont try this method if you dont also have a router.

you can likewise disable the router with the dmz internal toggle as long as your outgoing line is on the dmz line out physical port (usually #4 or #1 on the back of the router). use the internal interface of the router to turn this off and on.

K.

R'as al Ghul
07-04-2005, 14:32
Your shogun exe seems to be called shogunM.exe
and mine is called shogunW.exe

is this becous you have shogun MI and not WE?
The problem could be a MI problem i suppose,
I know that the origional shogun cant host games on Fakeserve,
But then again the origional shogun cant See games either.

I dont know what i can do to try and fix this problem, as i dont actualy own mongol invasion.
but i will see what I can find out,

Hi Shambles,

I think I pm'ed this already but for those who follow this discussion:
I've tried three .exe files. Vanilla, Mongol-Invasion & Warrior Edition.
All of them do the same for me, that is they don't listen to 18321
when I host.

:bow:

Drisos
07-04-2005, 14:39
I've tried three .exe files. Vanilla, Mongol-Invasion & Warrior Edition.All of them do the same for me, that is they don't listen to 18321
when I host.

I do follow this discussion. ~D

Can you find out what they do listen to when you host? ~:)

'Warrior Edition'? You mean WE? I thought that was 'Warlord Edition'. Is this just a little mistake or do you mean STW original? What is STW vanilla? WE or original?

sorry for inconviniece :embarassed:

*****

People who I saw being able to host:

...
Shambles
Trish
GodOfWar
47RoninToga
47RoninMethos
AggonyDuck
Shin-GaiJin
PaolinoPaperino
MizuJochiKhan
...

I haven't seen some players in the foyer yet, so there will be more.

*****

47Ronin Drisos

R'as al Ghul
07-04-2005, 14:40
Hi drisos,

if you use a website like whatsmyip.com it will return
the IP adress of your router, given to you by your
provider for the time of log-in. If your router is always
connected to the internet, this means you get a new one
every 24 hours. And you don't really need to know that one.

It looks as if your router has the IP 10.0.0.100
To check if this is correct, enter the IP into
the address bar of Firefox and hit return.
If the interface of your router shows up
then that's your router's ip.

The IP of your machine is a different one.
It could be that it's 10.0.0.138 as in your screeny.
Then your settings wouldn't be correct.
With the command winipconfig in dos (you're running Win98 right)
you can see your machine's IP. (We had this somewhere above)

R'as


Hello guys,

turns out my ip is 84.84.240.28

I can't open a port range like shambles can either.

What to do with the 'default server ip'? I don't know what it is and don't understand the online info about it either. should I use my comp ip, my router ip, or a standard ip adress? (in that case, which?)

Ientered my comp ip as outside adress and router ip as inside adress. Is that correct? It wouldn't work when I tried the opposite.

You see that it's different then the first time I forwarded. The ip adresses see m to be ok as the tcp says 'listen' now and I guess it works then. upd still says 'none' but that might be ok coz upd is used to let others see the game and then my comp does nothing with them so it says 'none'.

Hope it'll work now. Shambles, you want to check for me tomorrow in the afternoon? And R'as, I'd be glad to try for you too.

:dizzy2:

~:cheers:

R'as al Ghul
07-04-2005, 14:46
I do follow this discussion. ~D

Can you find out what they do listen to when you host? ~:)
They don't listen. That's the problem.
If they would listen my game should be visible.


'Warrior Edition'? You mean WE? I thought that was 'Warlord Edition'. Is this just a little mistake or do you mean STW original? What is STW vanilla? WE or original?

sorry for inconviniece :embarassed:

Vanilla: Shogun.exe, this one came with the original Shogun game. When
you've Mongol Invasion installed and fir up your game by using the original
Shogun.exe it works exactly as when you use the MI file.

WE: Warlord Edition



People who I saw being able to host:
...
Shambles
Trish
GodOfWar
47RoninToga
47RoninMethos
AggonyDuck
Shin-GaiJin
PaolinoPaperino
MizuJochiKhan

47Ronin Drisos

If any of you read this please post your configuration.
Router? USB or Network Card? Firewall?
Tell us everything....

~:cheers:

R'as al Ghul
07-04-2005, 14:52
Hi Kraellin,

thanks for stopping by.
Well, I've already tested hosting without my firewall but
it didn't work. I've it running now to monitor the connections.
Shogun has all access rights though.

My best guess, after toying with the EAsy program that came with the game,
is that because Shogun is a Win95/Win98 program it doesn't recognize my
USB-connected router. Easy says it can't find any Network-adapters.
Changing this back to my Network-Card might have an effect.
It is quite cumbersome to do but i'll try this as a last resort.

So, I've two more tests to do. Don't hold your breath though....
I'm not optimistic.

R'as


hi guys,

i've never used fakesrvr, but if it's a true server, then ALL the rules of servers apply just like they would on gamespy, or the EA servers or the Activision servers. generally, and this is very general, if you cant host but can connect to others, then you've got a firewall up somewhere that isnt allowing others to originate to you, or, your router is blocking on the necessary ports. that's the simplicity of it. USUALLY, it's a firewall, especially if you can connect to others.

if you cant connect to others or host, then it's a firewall/router OR a version mismatch.

[...]

K.

Drisos
07-04-2005, 15:28
I think I now know my router and PC ip for sure.

Some info coming up via PM. ~:)

Drisos
08-27-2005, 10:12
Personaly id find some 1 to come help me see if hosted games work without fire wall runing,
then systematicaly disable programs 1 by 1 untill i can host

sorry for late reply - I am all yours. Please pm me when you want to do such thing.

Anyone knows something about the 'logging in' problem. I mean the fact that much people need to try 4-7 times before they log in. and some people can't log in at all... I figured that might have something to do with port 8793, as the fakeserver uses it.. but then I don't get why it does work the 7th time...

anyone can explain this? what is wrong and how it should be solved?

Drisos
09-24-2005, 08:42
I ran into this accidentally.. it's about hosting with router:

http://p223.ezboard.com/fshoguntotalwarfrm11.showMessage?topicID=282.topic

:dizzy2:

R'as al Ghul
09-24-2005, 14:00
I'll look into it.
Seems like it is about Rome, though.

You can of course always try to forward the ports
mentioned on the first page.

~:cheers:

Drisos
09-24-2005, 19:56
I'll look into it.
Seems like it is about Rome, though.

You can of course always try to forward the ports
mentioned on the first page.

I checked it only briefly... sorry if it is not of any help. I thought it would be good info about port forwarding... we know which ports... only something else is going on... :dizzy2:

Just A Girl
11-14-2005, 14:07
iVE JUST HAD A THOUGHT.

You guys are trying to Host Freindly games right?
Cos You cant host competative games on fake server.....

Drisos
11-15-2005, 08:12
no competitive games for me... It's really my router blocking the games... ~:mecry:

x-dANGEr
01-19-2006, 11:21
Just out of curiosity, how can you know what ports is a game using? I do have a Windows firewall (XP) along with a router. All I do is get dazzled till I know what are the ports needed then I forward them. But how can you know what ports are needed anyway?

Just A Girl
01-19-2006, 12:10
I use keriop personal fore wall.
Whenever i connect to shogun i go and check what port is used.
These ports change.

When i host a game i go check which posts shogun is now using.
It always uses The same port when you host.

Thats how i know to forward that port.

Drisos
01-19-2006, 15:47
hmmm. When I fix the problem, I will be able to host, because I can now bypass my router. ~:) hooray! ~:)

Just A Girl
01-22-2006, 12:16
The foyer is much emptyer without you drisos.
Hope you fix your prob soon.
would be nice to battle again.

Drisos
01-22-2006, 14:26
I know my friend. I hate this situation as well... I don't know what to find worse - not being able to play while others are having games - or - knowing that because of my absence no one is playing...

I am not going to give up on this game. I can beat the computer! :yes: ~;)

Just A Girl
01-23-2006, 20:57
There is some sign of slight promis BTW.

from what A nother member said.

It seems they were able to log in to the foyer Quite easily when they accidentaly installed Warlord ediiton Over there origional STW folder.
(Mistaing warlord edition for the MI expantion)

Given the fact that the origional shogun suffers no real log in probs wven under XP.
And this chance discovery was made.

I am begining to beleve that there is a file/folder in the origional stw, game directory That is missing or prehaps diferent in WE.
It could even be a registry matter, which could be discoverd quite easily now we have some new data.

With any kind of good fortune.
this will be the case.
and a simple matter of trial and error of adding origional STW files to a nother install of WE could indeed allow us to Distribute the missing file to all who have log in problems.

Alternetavly if its a regestry problem,
A similar trial and error course of action could be taken with adding STW registry strings to the WE registry strings.
This could also be easily distributed.

I am quite exited about this new discovery my self.
But I will try not to get my hopes up about it.

:bow:

Drisos
01-25-2006, 06:32
Ok I think I understand... a bit. Hmmmm. I have stw original as well. I will first try installing that, configuring and logging in. Then later you can tell me what to do with the folder and files etc ~;)

Don't have time today sadly.. will be friday I think.

Just A Girl
01-25-2006, 10:58
Try inctalling origional shogun.
then install warlord edition to the same place.

So it replaces files when it installe.

Drisos
01-25-2006, 16:10
So I pick the shogun original main folder as we installation place?:idea2:

oki... will try tomorrow or friday.

Just A Girl
01-25-2006, 20:26
Yes.
It seems tomi says, Did that by mistake Thinking he had MI, (the expantion)
he seems to have installed WE to the origional shogun foledr like you would do with an expantion.

And he was able to log on to fakeserver.

he then relized his mistake and installed WE again Properly ths time.
He was unable to connect to fakeserver easily with the properly installed WE.

So hopefully if you install WE to the origional shogun folder You 2 will be able to log on with ease.

I recently Deleted the origional shogun from my pc. (the cd's are broken and i have WE any way)
So now i cant go and check which files are difernt :(

Its quite frustrating as i had STW origionall installed for ages n ages.
And have only just deleted it.

Shaka_Khan
03-11-2006, 10:13
If I want to host a game, do I open the ports like this?

...ChatserverPort = 8793
ChatserverPort = 18321...

or like this?

...ChatserverPort = 18321...

Drisos
03-11-2006, 11:17
Hello Shaka,

I'm afraid I don't totally understand. The ports needed for hosting seem to be 8793 and 18321. those two should be openen at router and firewall.

Router will cause more problems then a firewall. You can configure most firewalls easily to allow shogun to have contact with the internet.

If you have a router, and really want to host, there's an easy but fairly expensive way to achieve your goal. Get a looooong usb cable and plug it in your computer, and in your modem. plug out the router, and see if you still have connection. if yes, try hosting a game. It will work, almost certainly. ~:)