View Full Version : Unspecified Error CTD

02-20-2008, 12:06
Hi FactionHeir,

I started playing VanillaMod + Ornamentum graphics as we discussed before. Everything worked great until I entered the first battle (i.e. on the battle map) when I got an 'unspecified error' CTD. I'm presuming that there must be a conflict between files somewhere? Any advice on this would be great. But on the strat map things seem to be working OK.

02-20-2008, 12:15
Hmmmm check if you got

Someone in your M2TW folder and subfolders. I made sure to get rid of them in VanillaMod, but if you ever unpacked something on your end, or maybe Ornamentum had those files, you will get the battle CTDs. With those two files deleted, all should work well.

If it continues, try doing some errorlogging (look at the original VanillaMod.cfg from the archive and copy/paste the top part with errorlogging into your current VanillaMod.cfg).
Could be a conflict with the two mods in this case, but unlikely.

02-20-2008, 13:13
Hi FactionHeir,

That's great - I'll do as you suggest and let you know happens. Cheers!

02-21-2008, 10:03
Hi FactionHeir,

Although I couldn't find the files you mention above, I ended up reinstalling VanillaMod without 'Ornamentum' as there were a few stability problems. I think VanillaMod is better to play, so will stick with that.

Just one other thing: I have the MTW2 Gold edition, which has the 'Kingdoms' expansion pack bolted on. When I launch VanillaMod the MTW2 launch screen gives me the option of playing MTW2 or a Kingdoms campaign. What I'd like to know is: do the game modifications in VanillaMod impact on Kingdoms games or are they relevant only to MTW2 games?

Many thanks for your time and help!

02-21-2008, 11:58

Actually that's kind of odd that you get the option when starting VanillaMod, since its linked to medieval2.exe, and not launcher.exe.

The modifications are for M2TW without Kingdoms only, as each kingdoms campaign has its own units and traits. I don't have kingdoms so I can't account for those sadly.

02-21-2008, 12:37
Hi FactionHeir,

Thanks for this. Yes, I was surprised to get those options when launching VanillaMod and that's what prompted me to get in touch.

Actually I made an error! What happened was this: I put the game disk into my drive and then clicked on the VM batch file to launch VM. But my PC was obviously trying to launch the disk's startup screen - and eventually it did. I guess it beat VM to startup. And so I selected MTW2 and started playing, thinking it was VM.

But later I tried again. This time I waited for the disk startup to appear, quit from it, and then launched VM. Sure enough, it bypassed the Kingdoms startup screen and went straight to MTW2.

Now I know what happened and how to launch VM properly with the Kingdoms disk (actually it's MTW2 Gold with Kingdoms bolted on)!

But thanks for getting back to me. Now I'll play VM properly . . .