View RSS Feed

sit0208

After battle CTD...

Rate this Entry
Quote Originally Posted by Theages View Post
I also experienced after battle CTDs quite often. My system has 8GB RAM. I am using Vista x64. Rome therefore runs in 32 emulation mode ('WOW64'). I use the BI - exe.

A standard 32Bit program on a 32Bit OS can only use 2GB ('User RAM') The rest is for system. On Windows Server 2003 there is a recommendation to alter the boot.ini to set the ratio to 3:1 instead of 2:2 for applications like Exchange Server 2003, which can use more than 2GB. In the header of each exe-file there is an entry specifying if the program can use more then 2GB.

A previous poster in this thread suggensted that the after battle CTDs are due to memory management problems. That seems to be true.

Some time ago in some forum thread I can't remember (I can't even remember which game it concerned) I stumbled over a comment, that it could be generally useful to set the exe-file to be able to use >2GB RAM when using Vista 64 or Windows XP x64.

So I tried that on the BI-exe. The result was, that after battle CTDs occur much, much fewer times.

So I suggest that everyone who is plagued by after battle CTDs and uses a 64Bit Windows tries the same. The following instructions are based on using the BI-exe. But it should also work with RomeTW.exe and RomeTW-ALX.exe.
1. get 'Explorer Suite' from www.ntcore.com (freeware)
2. install it
3. make a copy of RomeTW-BI.exe'
3. right click on 'RomeTW-BI.exe'
4. choose 'Open with CFF Explorer'
5. in the left tree click on 'File Header'
6. in the right window click on 'click here' in the 'Characteristics' row
7. in the appearing window check the box in the line 'App can handle >2gb address space'
8. click 'OK' - button
9. click on 'save' icon
10. Run the game as usual.


For the following you really should know what you are doing.
I have not tried this on Windows XP 32Bit. I don't know if the alteration of the file header alone would work on that OS (or Vista32). I guess on XP32 you would additionally have to add the '/3GB' and '/USERVA=2990' switches to the line in the boot.ini that starts your Windows XP (eg:'multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect /3GB /USERVA=2990'
(change is in bold characters)

TAKE CARE. Altering the boot.ini may prevent your OS from starting. Before altering it you should make a copy of the boot.ini and install the recovery console that comes with Windows XP to be able to copy your save of boot.ini back in case the OS won't start after the alteration. Or you could duplicate the 'multi...' line in the section [operating systems] of the boot.ini and enable the boot menu to be displayed when booting the OS.

sample boot.ini:
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /USERVA=2990
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Submit "After battle CTD..." to Digg Submit "After battle CTD..." to del.icio.us Submit "After battle CTD..." to StumbleUpon Submit "After battle CTD..." to Google

Updated 01-07-2011 at 18:15 by TosaInu

Tags: None Add / Edit Tags
Categories
Uncategorized

Comments

Single Sign On provided by vBSSO