Results 1 to 12 of 12

Thread: Enabling Javascript on my browser

  1. #1
    Dyslexic agnostic insomniac Senior Member Goofball's Avatar
    Join Date
    Jan 2004
    Location
    Victoria, British Columbia
    Posts
    4,211

    Default Enabling Javascript on my browser

    Ok, having troubles here. A certain website (alright, Facebook, if you must know, yes, I know I'm a social surf addict) keeps giving me a message that Javascript is not enabled on my browser, and because of that many of the functions on the site will not work correctly for me.

    I have done the following:

    Select Tools > Internet Options.
    1. Click on the Security tab.
    2. Click the Custom Level button.
    3. Scroll down to the Scripting section.
    4. Select Enable for Active Scripting and Scripting of Java Applets.
    5. Click OK.
    6. Select YES if a box appears to confirm.
    7. Click OK. Close window.
    8. Reload page.

    However, I am still getting the "Javascript not enabled" message.

    Can anybody tell me what I'm doing wrong?
    "What, have Canadians run out of guns to steal from other Canadians and now need to piss all over our glee?"

    - TSM

  2. #2

    Post Re: Enabling Javascript on my browser

    It seems the problem might be that Facebook has somehow ended up in the "Restricted Sites" list in Internet Explorer.

    Firstly open up Internet Options. On IE 6 select "Tools" and then "Internet Options". On IE 7 with the menu bar hidden, press "Alt" and then select "Tools" followed by "Internet Options".

    Scroll to the "Security" section and select "Restricted Sites".

    Click on the "Sites" button.

    If "www.facebook.com" is on the list, select it, and then click remove.

    Select Ok, and then Ok again.

    If "www.facebook.com" isn't on the list, you may wish to check under the "Trusted Sites" list to see if it's there. If it is, then remove it and, for the future, switch the zone slider security to "Medium".

    If Facebook isn't on either list them I'm a little confused over what could be causing the problem. You may want to try switching to an alternative browser, such as Flock or Firefox. This is probably advisable anyhow - Internet Explorer, particularly Internet Explorer 6, is a terrible browser when it comes to security, customisability and overall level of features.

    If you're a social networking adict, then Flock will most definitely appeal to you with its integration with MySpace, Photobucket, Facebook, YouTube and similar sites.

    Last edited by Omanes Alexandrapolites; 04-01-2008 at 21:41.
    Dawn is nature's way of telling you to go back to bed

  3. #3
    Dyslexic agnostic insomniac Senior Member Goofball's Avatar
    Join Date
    Jan 2004
    Location
    Victoria, British Columbia
    Posts
    4,211

    Default Re: Enabling Javascript on my browser

    Thanks for the response. Your rock. I'm going to implement all of your advice.
    "What, have Canadians run out of guns to steal from other Canadians and now need to piss all over our glee?"

    - TSM

  4. #4
    The very model of a modern Moderator Xiahou's Avatar
    Join Date
    Aug 2002
    Location
    in the cloud.
    Posts
    9,007

    Default Re: Enabling Javascript on my browser

    Or just use firefox.
    "Don't believe everything you read online."
    -Abraham Lincoln

  5. #5
    Iron Fist Senior Member Husar's Avatar
    Join Date
    Jan 2003
    Location
    Germany
    Posts
    15,617

    Default Re: Enabling Javascript on my browser

    It also happens when noScript in Firefox blocks scripts on the page, obviously (well yeah, a bit obvious but sometimes people just forget...).

    Tried installing Java script or just installing it over your already installed version?


    "Topic is tired and needs a nap." - Tosa Inu

  6. #6
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Enabling Javascript on my browser

    Hello,

    I'm having Javascript problems on IE since the day I started to use WinXP. I install the latest Java Runtime, it works properly for a few weeks and then it collapses.

    I installed Opera to get hasslefree Java. FireFox seems to perform fine too.
    Ja mata

    TosaInu

  7. #7

    Default Re: Enabling Javascript on my browser

    Quote Originally Posted by Husar
    It also happens when noScript in Firefox blocks scripts on the page, obviously (well yeah, a bit obvious but sometimes people just forget...).

    Tried installing Java script or just installing it over your already installed version?
    You can't install Javascript. Browsers come with a Javascript interpreter. Whether it's enabled or not determines if the code is parsed when the page loads.

  8. #8

    Default Re: Enabling Javascript on my browser

    If you're using the MS Java that comes with Internet Exploder, then this is the problem as it is no longer developed. You need to download the Sun J2RE and install that. All of your Java problems should then be over.

    http://www.java.com/en/download/manual.jsp

  9. #9
    Iron Fist Senior Member Husar's Avatar
    Join Date
    Jan 2003
    Location
    Germany
    Posts
    15,617

    Default Re: Enabling Javascript on my browser

    Quote Originally Posted by alman7272
    You can't install Javascript. Browsers come with a Javascript interpreter. Whether it's enabled or not determines if the code is parsed when the page loads.
    Oops, you're right, maybe I thought of Java runtime.


    "Topic is tired and needs a nap." - Tosa Inu

  10. #10
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Enabling Javascript on my browser

    Quote Originally Posted by Caravel
    If you're using the MS Java that comes with Internet Exploder, then this is the problem as it is no longer developed. You need to download the Sun J2RE and install that. All of your Java problems should then be over.

    http://www.java.com/en/download/manual.jsp
    That's where I got it from Caravel. But after a week or so of working with IE it stops working.
    Ja mata

    TosaInu

  11. #11

    Default Re: Enabling Javascript on my browser

    Ah... Javascript not Java? Sorry, totally different thing.

    1) Download and install Windows Script:

    http://www.microsoft.com/downloads/d...b-95a22b832caa

    2) Try using an alternative browser to MS IE, such as Opera or Mozilla/Firefox: Much more reliable.


  12. #12
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Enabling Javascript on my browser

    I do have other browsers installed too Caravel.

    It's a bit odd that IE never managed to behave for more than say three weeks during all those years (fresh install, SP1, SP2).
    Ja mata

    TosaInu

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO