I'm just curious if anyone else playing Gaelic Kingdoms or Blood, Broads and Bastards (BBB) mod ever experienced the infamous "medieval 2: Total War encountered an unspecified error" message.
I get it about 5 or six turns into the campaign during the "Next Turn" loading sequence and its always when the factions loading display at the top is on The Moors.

This is happening when I play English on Gaelic Kingdoms mod but I also remember something similar when I tried the BBB mod a few weeks ago.
To eliminate a few possibilities, I've tried this with a completely new fresh install of M2TW and Kingdoms.
I then installed the recent Kingdoms Update to see if that fixed things, but it didn't.
I dont think its graphix related because I play the first 6 turns fine and I also play Battles fine. Also, I can still play both the Grand Campaign (unmodded) and the Kingdoms campaigns (unmodded) without any issues.
I also dont think is corrupted save files, because I've RESTARTED the campaign several times and just hit end turn repeatedly without doing anything and it always happens on the 5th-6th turn transition when The Moors are loading.

I'm not sure what files to look at or what to look for, but if anyone has any ideas please advise.

(BTW, this is specifically a mod issue so I didnt think it belonged in the technical assistance forum. And I dont know if it is a Gaelic Kingdoms or BBB issue since Gaelic Kindoms includes BBB so I didnt want to post this in either of their topics. Starting a new topic here was the only thing I could think to do.)