Page 9 of 9 FirstFirst ... 56789
Results 241 to 252 of 252

Thread: EB for Macintosh - questions & support thread

  1. #241

    Default Re: Mac Version - Mac version created & hosting organised, who do I ask for permissio

    Edwin,
    I have bought Rome: Total War - Gold Edition from the Mac App Store, and want to install Europa Barbarorum. I didn't really get the steps on the previous page, so could you post a more in-depth from-the-beginning post with all the details? Thanks!
    Last edited by Iabma; 03-11-2014 at 00:08.

  2. #242

    Default Re: Mac Version - Mac version created & hosting organised, who do I ask for permissio

    I have the 1.2 version from the DVD, and I still can't get EB working in BI or regular. First, it was giving me the "you must select an item" error when I start the campaign and wasn't letting me start a custom battle. I tried the fixes like deleting that map file, copying/renaming folders, etc that are posted above. Now, it crashes when I start a custom battle, and when I choose my faction in campaign, it goes back to the main menu.

    Is it my RAM? Something I have to limit for the game to work?

    I'd play it in my Windows VM if it weren't for that bug in RTW where the campaign map lags extremely badly on some systems.

  3. #243

    Default Re: EB for Macintosh - questions & support thread

    Never mind, I managed to download and install it, but I can't play the campaign because when I click it it says "Please select an item from the list." Also, custom battles are totally messed up i.e. first, the units are all the same, and second the battle literally doesn't load, but just goes back to select factions page.

  4. #244

    Default Re: EB for Macintosh - questions & support thread

    Iabma, same thing happens with me.

  5. #245

    Default Re: EB for Macintosh - questions & support thread

    Hello, any updates here?

    I have the same issues described in the above posts where clicking on the EB Campaign I get a dialog box that says 'please select an item from the list'

    For reference sakes this is my install info...

    Launcher About Rome: Total War - Gold Edition v1.4.2
    Launcher Advanced: -mod:EB

    Copied the entire EB directory from the EuropaBarbarorum.dmg into /Applications/Rome Total War/Rome Total War.app/Contents/Resources/Data
    (nb: a previous post stated to copy into the data subdirectory, that's incorrect)

    Moved the Rome Total War.app directory to ~/Library/Containers/com.feralinteractive.rome/Data/Library/Application Support/Feral Interactive/Rome Total War

    Start the game. I can see the mod's different logo, read the different wise men quotes. I can load the save game included and the game starts. I can hear the mod's music, I can see the different graphics and even accept a betrothal. Sadly I'm really not interested in playing whichever that faction is.

    TLDR:

    1- Click Play EB campaign don't work says select an item from list
    2- Custom battles don't work, after setting up armies it sends you back to faction select

    BTW, thanks to all involved here

  6. #246

    Default Missing files

    Hi guys,

    I did something rather silly the other day but I cant remember doing it and dont even know how I went about doing it. I was playing away just fine 2 days ago, shut the game down and then went back to open the game back up today and I got this weird message saying that Rome Total War is installing.

    A bit of background: I'm playing on a Mac (works absolutely fine, a few CTD's here and there but I'm several hundred turns in and still going strong with the Macedonians) I have neglected to update RTW:BI for ages and it has been sitting there waiting to be updated for ages with that little empty bar sitting above in the applications folder. So I have had to open that game a different way for a while. I go into the RTW folder, right click in the RTW:BI image and select "Show Package contents". From there I click on MACOS folder, then once in there click on the black/gray image that says "Rome Total War". This opens the game through the terminal window and Presto, the game opens and runs perfectly. However, I noticed today that the folder had a lot less files in it than normal for some bizarre reason but tried to open it anyway, and then I got the message about it trying to install again. After some not so difficult sleuth work, I found a bunch of missing files in the damn trash. These are the files I found:

    -barbarian_invasion (normal blue folder)
    -barbarian_invasion 6.18.09 PM (normal blue folder)
    -barbarian_invasion_regions_and_settlement_names 6.18.24 PM.txt
    -barbarian_invasion_regions_and_settlement_names.txt
    -imperial_campaign_regions_and_settlement_names copy.txt
    -map.rwm (back/gray image)
    -map.rwm 8.01.54 PM

    What I'm hoping will work is if one of you guys applies your massive brains to this issue and can find out where these files actually belong (I just stuck them into some arbitrary folder in the hopes of it working, shocking news: it didn't) then the game will be able to fire back up again. Otherwise I might have to install the whole thing again? Massive thanks whoever can help me out on this!

  7. #247
    Arrogant Ashigaru Moderator Ludens's Avatar
    Join Date
    Nov 2003
    Posts
    9,001
    Blog Entries
    1

    Default Re: Missing files

    Moving above post to EB for mac thread

    I don't run the mac version myself, but AFAIK map.rwm should be regenerated if missing, so that can't be the problem. The barbarian invasion invasion files likewise shouldn't matter. Only the missing imperial_campaign file may cause problems. I think it belongs in the data or world/map folders.
    Last edited by Ludens; 12-04-2014 at 21:37.
    Looking for a good read? Visit the Library!

  8. #248

    Default Re: Missing files

    Thanks for that. I tired it but that didnt work either. I'm not surprised really because with my limited technical know-how I was liable to throw the files anywhere. SO what I chose to do is go for a clean install.

    This is where I have stalled again.

    I downloaded from the app store that latest RTW with BI. In my applications folder the image for this looks split in half horizontally, with the RTW above the BI image. It is the latest version as well. Then I downloaded the EB files and the installer for them. I have been getting the same message in the terminal about making sure that RTW is installed in the Applications folder and have tried moving the RTWBI image into a separate folder WITH the Rome data script in the Applications folder (the one with the image that looks like a little robot) and running it from there but to no avail. I remember last time I tried installing I had the same problem but somehow I found someone with the same issue and they managed to solve. Please believe me when I say I have pored over many of the pages in this forum and others before asking for help here but I'm really stuck. It also doesnt help that I am not very IT gifted so any explanations I find are usually have far too many tech terms in them that I just dont understand.

    But if someone has had this problem in the past or has experience fixing this or knows anyone that can help I'd really appreciate it. Many thanks.

  9. #249

    Default Re: Missing files

    Alright, update to that latest issue.

    I found some instructions on Reddit, of all places on how to install EB. So, I put the EB file into the RomeData file, put the "-mod:EB" business in there and hey presto, EB fired up. Then I ran into my next two obstacles. First, I have RTW from the app store with the BI expansion but I can tell that EB is running off the RTW executable and not BI because when the game starts I see the original start video and not the new BI video. So, any thoughts on how to make EB run through the BI executable? When I had it installed last time it was so I know for sure that it is possible.

    Second obstacle is that I am getting the "Please select an item from the list" message come up when I select EB main campaign. However, I have seen that many people are having this issue in this thread so I'll do some research on how to fix that, but I need to hurdle obstacle one first.

    Any thoughts? Thanks heaps to anyone who can help.

  10. #250

    Default Re: Missing files

    Hi all,

    I'm guessing that most people are probably playing EBII right about now, but I've got a really good campaign going still on EBI and I'm itching to get back to it so I'm hoping someone can help me out a little here.

    As per my previous post, I am still having installation issues, primarily the one which just says "process complete" without actually installing EB. After some research, I found that with the app version of the game (which has the BI and Rome icon appear as a split color circle icon) does not come with the RomeData.dmg that I need to install EB. Does anybody know where I can find this at all? Once i find this little file, I will probably be able to install the game.

    Any help here would really be appreciated. Many thanks.

  11. #251

    Default Re: EB for Macintosh - questions & support thread

    Quote Originally Posted by YD23 View Post
    I was among many people with the "please select an item from the list" error when trying to start EB, however, I found a way around this with some other people. Not sure if this was mentioned in this thread but here are the directions anyway. Make sure you follow them precisely.

    For EB to work, install it onto the RomeData.dmg. (make original .dmg read/write the copy paste the downloaded EB1.2 from the EB website onto the .dmg)
    If you try to start the EB campaign you will probably encounter the above campaign error. To fix this, go in EB / data / world / maps / campaign, and copy the 'imperial campaign' folder- paste in the same directory- rename as 'Barbarian Invasion'. Then, go into EB/ data / text, and find 'imperial_campaign_regions_and#_settlement_names.txt'. C/P the same directory - rename as 'barbarian_invasion_regions_an#d_settlement_names.txt'.

    Some say you can play with bi, but seeing that on twc EB people mention bi being incompatible I just play with regular rome total war through the feral launcher.


    By the way, I am not sure if I am the only one who gets this minor glitch in vanilla or eb campaign, but my characters do not make any sounds as opposed to the PC version. If anyone knows a way to get around this issue please let me know how. :)

    I am a moderator on twcenter.net, my name is YD23, so if you need me to be even more clear with the above directions please send me a PM on that forum. (I'm more likely to be there)



    EDIT:
    For those trying to install EB through the feral mod installer you're a bit out of luck. I as well get the "please make sure Rome is in the application folder" even though it is. I found a way around this. First make a folder called Rome Total War in your application folder. Move Rome Total War.app in there. I would also put the mod installer in that same folder and run it. When it says would you like to enable mod support press NO. Then press "yes" when it asks if you want to rebuild your data. It will go through and will actually make the .dmg read/write and will also install any mounted mods. It's very strange because when you press "yes I would like to enable mods", that doesn't work, but when you press NO, it does.

    EB WILL not be installed through this, however. After the "mod installer" converts your .dmg to read/write you still have to paste the EB (freshly downloaded original copy of EB from EB site) into the RomeData.dmg. Then proceed with the very first directions in my post to get into the campaign.
    Hope this helps. :)
    I have a Macbook early 2011, i bought from the Feral Websites and this solution works perfectly. I have bought the gold edition. No problems at all, great! And thanks !

  12. #252

    Default Re: EB for Macintosh - questions & support thread

    I've followed the instructions via the Quicktime video on both the physical disc and App version to no avail. Only constant error messages with either finding the app or within the Terminal. I've tried all the bizarre tricks of putting it in different folders and telling the commands to do the opposite of what they're supposed to do. I wish someone could compile the instructions and put it in a single post. At this point it seems like I'm either late to the party or the mods have stopped working and no one has updated this forum about it.

    I can't find a "preferences" folder, neither is there a RomeData.dmg.
    "cp: /Volumes/RomeData/EB: No such file or directory"
    Last edited by Trinitarian; 11-15-2015 at 17:52.

Page 9 of 9 FirstFirst ... 56789

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO