Results 1 to 2 of 2

Thread: Current MOD Compatibility

  1. #1

    Default Current MOD Compatibility

    Hello,

    I've only recently gotten Shogun 2, as it's been some years since I had a computer capable of running high-end games. I've been playing for a few months, but I wanted to try some of the MODs currently out. My problem is that I've seen conflicting reports about whether or not any mods will work with my current version of S2, OS, Steam, etc.

    SW is fully up to date via steam, as is my steam. I'm running the game in bootcamp, Windows 7 Home, on an iMac. I have S2 and RotS, but I have not yet purchased FotS.

    So, could someone let me know if there are mods that would work with my setup? A simple yes would be great -- specific popular mods would obviously be great.

    Thanks so much.

  2. #2
    Moderator Moderator Gregoshi's Avatar
    Join Date
    Oct 2000
    Location
    Central Pennsylvania, USA
    Posts
    12,959

    Default Re: Current MOD Compatibility

    Welcome back Charley. Alas, I can't help answer your question. Your best bet to get an answer to your question would be to head over the Total War Center (TWC) - they have a much more active modding community there.
    This space intentionally left blank

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO