Results 1 to 3 of 3

Thread: Flat and featureless

  1. #1

    Default Flat and featureless

    Although I have been playing this game forever, I only recently noticed a strange thing. When you start MTW from scratch (not when you start a new game within a session) the first battle always takes place on flat and featureless terrain - regardless of what the Borders text says the terrain should be. I've checked across various Mods as well as vanilla, and this always seems to happen - also regardless of faction or province or era. Has it been noticed before? Is there any way to avoid it? The pre-battle image shows nice interesting terrain - and then up pops flat and featureless to rain on my immersion.

    Click image for larger version. 

Name:	00000000.jpg 
Views:	70 
Size:	43.1 KB 
ID:	19686
    Last edited by western; 06-01-2017 at 14:08. Reason: trying to add screenshot

  2. #2
    Second-hand chariot salesman Senior Member macsen rufus's Avatar
    Join Date
    Dec 2004
    Location
    Ratae Corieltauvorum
    Posts
    2,479

    Default Re: Flat and featureless

    Now that's weird, Western.

    I've come across the map before, although not in the same circumstances. This is the 'default' map that plays whenever the game calls for a map-type that doesn't exist, and normally when it crops up I am forewarned by getting a black (ie missing) pre-battle image. It can be quite entertaining in castle assaults

    However, I have never experienced the general case that you report in the first battle of every campaign. Clearly in your case, the correct map does exist because a pre-battle image comes up, so the question is why the map is not called correctly. For me, it doesn't make any difference between vanilla or mods, I always get a 'proper' map for the first battle - except in those cases where I have a missing map and it would be missing on the first, third or ninety-ninth battle

    So I can't offer any solution, I'm afraid, but I'd be interested to try a couple of tests.... on a new session, before starting a new campaign, try a custom battle to see if the same issue arises - if it does, you may be able to then start your campaign normally. And second, try the tutorial campaign, and see if that does the same. Of course, your options on this might be limited with mods.
    ANCIENT: TW

    A mod for Medieval:TW (with VI)

    Discussion forum thread

    Ancient TW2: Eastern Empires is under development again

    Featuring: Rise of Persia, Alexander's Conquests, Wars of the Diadochi

  3. #3

    Default Re: Flat and featureless

    Excellent thinking Macsen. I tried custom battle with hilly terrain and got the right pre-screen but then flat and featureless default. Then I switched to my real campaign and the first battle popped up with the right terrain - so the workaround worked. I can only play on steam these days, so just maybe the issue is related to steam version. But as you say, it's weird and hard to understand - computer can't find the right map first go, but thereafter it can, so where's the logic?
    That's a rhetorical question by the way - there is no logic, but I'm glad I asked for ideas because your workaround wouldn't have occurred to me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO