The year is 266 bce, I am playing the Romani faction. I frequently crash on the campaign map, sometimes when I click on a general and always when I attempt to open the mercenary scroll. I tried to freshly install a few times but it still occurs. This doesn't happen in battles, only the campaign map. I've tried change my audio as a post suggested, re-installed a few times, but I haven't found another post with this specific problem. I am on windows 10.

I have been using console commands to speed things up as I am very interested in what's actually new in 1.32. I do not think this is causing the issue. This is a folder containing all my save games from the start of the campaign to where I am currently at. The point i'm at is conveniently titled "Roma".

Thank you, L. C. Sulla

I also would like to note that the multiplayer for version 1.32 is completely broken, sometimes me and my friend will have the same version and sometimes we won't at random. And the unit rosters are completely mixed up, multiple factions missing units and having other faction's unit (Carthage having spartan hoplites lol). This post is mainly about my singleplayer experience but I would like to know if there is a reason 1.32's multiplayer is broken to this degree.

Also I've read constantly that the Lorica Segmentata would not be included yet I see new units that are from 100 CE? Does the game last longer than 14 CE now? Why does Greece have crossbowmen (They're kind of broken btw, they do way too much damage for what should be an early crossbow) and no one else has them?