Results 1 to 5 of 5

Thread: CTD before battle, tried everyhing, including LAA

  1. #1

    Default CTD before battle, tried everyhing, including LAA

    Hello, I know there are bunch of "CTD before/after battle" topics, but I have tried everything and still get it. I constantly get CTD before starting battle, during loading (once just after starting battle), it is when defenders attacks me at the end of the siege. What is weird, if I attack this or another village and attack them instantly (they have no walls), then I get an error after about 20 minutes of battle.

    I would include log, but for some reason I have "You may not post attachments". I get bunch of errors but as far I've investigated these are "normal" errors, which shouldn't prevent normal gaming, such as "Error in battle script command 'unit_set_experience': invalid unit label 'Eu39'." or Error in battle script command 'define_unit_group': invalid unit label 'MAu1'. The last error is:
    [system.rpt] [error] Unspecified error. Please compress your error log in a zip format and upload it on the EBII technical help forum.

    Kingdoms 1.05
    EBII 2.35
    Windows 10
    Intel HD Graphics 4000 (integrated), driver version 16.08.2018
    8 GB RAM memory
    Windowed, borderless, custom resolution 1600x900

    What I did:
    - Followed instruction (including starting vanilla camapaign and finishing the turn, installing DirectX and C++ libraries, installing outside Program Files)
    - Shaders set to version 1, all graphic settings to low, V-Sync turned off.
    - Large Address Aware in kingdom.exe set to True. Tried with LargeAddressAware.exe and 4gb_patch both. 4gb_patch does the same. LargeAddressAware.exe shows me that this flag is set to True.
    - kingdom.exe set to run as admin and as Windows 7
    - deleted the map.rwm file (in: "mods\ebii\data\world\maps\base") (as suggested in https://forums.totalwar.org/vb/showt...-after-battles). Of course I also tried staring battle many times before deleting/renaming this file.
    - starting new campaign with same faction
    - starting battle from another position/angle on map
    - exited all programs when launching Total War.
    - no problem when auto-resolve

    Please help. I loved EBI, but it was extremely unstable, I hoped that EBII will be better in that matter. If needed I can upload trace log too (though it is over 80 MB).

  2. #2

    Default Re: CTD before battle, tried everyhing, including LAA

    Do you get a message when the game crashes or does it just return to the desktop ?
    Also, do you have another GPU on your laptop ?
    If you have a dedicated card, you can set which one to use in the control panel of the said GPU.
    I know that you said that you lowered your graphics but EBII units models are of a far more detailed than the base game.

    Also the best thing would be to attach the log but for that you need a certain number of posts on the forum, and I don't know how many (maybe 5).
    Last edited by Domaje; 04-18-2020 at 18:02.

  3. #3

    Default Re: CTD before battle, tried everyhing, including LAA

    Quote Originally Posted by Domaje View Post
    Do you get a message when the game crashes or does it just return to the desktop ?
    Also, do you have another GPU on your laptop ?
    If you have a dedicated card, you can set which one to use in the control panel of the said GPU.
    I know that you said that you lowered your graphics but EBII units models are of a far more detailed than the base game.

    Also the best thing would be to attach the log but for that you need a certain number of posts on the forum, and I don't know how many (maybe 5).
    I just get "Unspecified error. Please compress your error log in a zip format and upload it on the EBII technical help forum.".

    No, it is my only card. I am aware that this is not the most powerful graphic card in the world ;), but I've played a lot in Stainless Steel and some in Broken Crescent (another total conversion mods of M2TW) with High graphic settings and never had a single problem with crashing.

    Well, I still cannot find an option to attach a file, maybe I am looking wrong. I've shared it at google drive instead:
    https://drive.google.com/open?id=1Ny...BaKP3DnyfOw1w_

  4. #4
    EBII Hod Carrier Member QuintusSertorius's Avatar
    Join Date
    Apr 2008
    Location
    UK
    Posts
    21,280

    Default Re: CTD before battle, tried everyhing, including LAA

    You can't post attachments until you've posted a minimum number of times - it's a forum setting to stop spammers. I think it's 25 posts.

    Can you get a trace log and upload that? It's not clear from that error log what's happening at the moment of the crash.
    Last edited by QuintusSertorius; 04-21-2020 at 13:05.
    It began on seven hills - an EB 1.1 Romani AAR with historical house-rules (now ceased)
    Heirs to Lysimachos - an EB 1.1 Epeiros-as-Pergamon AAR with semi-historical houserules (now ceased)
    Philetairos' Gift - a second EB 1.1 Epeiros-as-Pergamon AAR


  5. #5

    Default Re: CTD before battle, tried everyhing, including LAA

    Sure. But I don't think it contains useful info.
    https://drive.google.com/open?id=1WI...XPkx-eQ0ZuDDs2

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO