Results 1 to 7 of 7

Thread: Problem with the rebels (noob modder)

  1. #1

    Default Problem with the rebels (noob modder)

    Im from brasil, so dont expect a good english!!

    Im playing with the rebels, and im experimenting some problems i want to resolve. Dont need to tell me this game was dont make to paly with the rebels, senate, etc.. i know it. ;)

    The voice of rebels are with the voice of romans. Looking in the sound files (more exactly the export_sounds..) i find the sounds separate by cultures. So, my idea, create a new culture, the slave culture. What the file i can create these new culture and linkage with the slave faction?

    And, when i desembark with my troop, CTD!! I think is because the sound, but any idea i will thank.

    The great big problem to me, all this stuff will be more easy, if the show_err work with me. Aparently, just CTD, and dont show the message error. With the map i recreate (i make modifications in mundus magnus) i need to try enter the map, then the game back to menu, after that i enter in imperial campaing, and appear the error and ctd. If i enter in mundus magnus again, just ctd. Any ideas?

  2. #2
    The Dark Knight Member wlesmana's Avatar
    Join Date
    Jan 2005
    Location
    Indonesia
    Posts
    602

    Default Re: Problem with the rebels (noob modder)

    You can't create new cultures. It's hard-coded. Thus the CTD.

    If I'm not mistaken, rebels are using all 6 cultures, depending on the area/type.

  3. #3
    Proud Knight of the AMC Member RTW King's Avatar
    Join Date
    Jul 2005
    Location
    Dal Riada, Scotland
    Posts
    327

    Default Re: Problem with the rebels (noob modder)

    Yeah, they are. And plus, it wouldn't be right to have Irish rebels sounding the same as African rebels.
    Join the AMC. Down with rappers!

  4. #4

    Default Re: Problem with the rebels (noob modder)

    Thnks for the help.

    RTW kings, if i undstand, each rebel will have the particular sound of their culture they belong, right? Well, in the battlefield, all sounds ( i mean general orders, "the day is ours", "its a great day for roman army", the initial discurse to the troops, when u take a city say "this city is roman") are to romans, as if i a roman. Its is not right, right? Is that hard coded to i resolve?

  5. #5
    The Dark Knight Member wlesmana's Avatar
    Join Date
    Jan 2005
    Location
    Indonesia
    Posts
    602

    Default Re: Problem with the rebels (noob modder)

    The culture is hard-coded BUT there's a way around it. However it requires a LOT of work (text editing).

    What you need to do is to have your own voice slot, dedicated for your faction. Since you want to play the rebels, you'll to take up a slot in EACH culture. The slots of voices are as follows: Light_1, Medium_1, Heavy_1 and General_1. There's also Female_1 but I don't think Romans have them so ignore that for now.

    Let's say you want to use the Light_1 slot, so you'll need to change all the non-Rebel units to have voices OTHER THAN Light_1. Then you assign all your Rebel units to use Light_1, and edit it to have whatever voice you want.

    That's option 1.
    Option 2 is untested: I'm not sure if you can create a new voice slot in a culture. If you could, this would be easier, but it still requires you to do heavy text editing to find the voices you want/don't want.

    In fact, I'm going to test option 2 in a bit so I'll let you know.

  6. #6

    Default Re: Problem with the rebels (noob modder)

    I will work this too.Tnks so much.

  7. #7
    The Dark Knight Member wlesmana's Avatar
    Join Date
    Jan 2005
    Location
    Indonesia
    Posts
    602

    Default Re: Problem with the rebels (noob modder)

    I've tested my Option 2 from above and sadly, it doesn't work. It seems the soldier voice slots are hardcoded so only Germans got an extra one (Female_1).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO