Page 1 of 2 12 LastLast
Results 1 to 30 of 38

Thread: Beta 8...A problem??

  1. #1
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Beta 8...A problem??

    Thought I should bring this to everyone's attention.

    I have Three installs of VI on my PC. All have been installed 'clean' (from the discs not copy/paste). VI...Samurai Wars..and now Samurai Warlords Beta 8.

    I have never ever had a problem with hosting games in any of the Total War series. Shogun, Medieval, Rome and Medieval2.

    Since installing Samurai Warlords Beta 8 I am now unable to host any games in any of the VI installs. That is, I host a game but other players cannot see it. I am able to join a game that is hosted by another.
    This has been play tested with three different players and all are getting the same result. Cannot see the game.
    Two of the three have tried hosting and they also have the same problem as me. I can see other beta 8 games that are being hosted with the game info, and the 'version conflict etc' for games that are not beta 8.

    CBR suggested that I host a LAN game and then try hosting in the multiplayer game lobby. Apparently others have had this same problem and hosting a LAN game has corrected the problem for them. This I have done but the problem still remains.

    It is NOT a firewall issue. I have shut down firewalls, disabled firewalls and even (silly thing to do online) have disabled both firewalls so that there was no protection at all and, incase someone suggests it, I have even disabled AVG (anti virus) which showed a virus when Beta 8 was first installed.(posted in my Warning thread) here

    There is definately a problem with Beta 8. A possible bug with the auto installer??? I have never been a fan of auto installers preferring to manualy instal the files myself. That way I know where the files have been installed to.

    RTW/BI and M2TW I can still host with no problems.

    Does this mean that the only time I would be able to play Samurai Warlords would be if any of the 'team' are online and Sundays only???

    I want to be able to host a game when/that is convenient for me to play.
    Last edited by Jochi Khan; 06-04-2007 at 19:27.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  2. #2

    Default Re: Beta 8...A problem??

    Well I don't see how the problem can be the beta 8 because it only installed to one of your three MTW/VI installs. When was the last time you hosted an MTW/VI game? Maybe something else has changed in the interim.

    I've been told that the Zone Alarm firewall stops the hosting of MTW/VI games even if you turn the firewall off.

    _________Designed to match Original STW gameplay.


    Beta 8 + Beta 8.1 patch + New Maps + Sound add-on + Castles 2

  3. #3

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Puzz3D
    I've been told that the Zone Alarm firewall stops the hosting of MTW/VI games even if you turn the firewall off.
    I don't know where you got that information but it is incorrect. I did all my hosting in STW/MI, MTW and VI this way.
    Out of interest, how was the 'host a LAN' solution discovered? It would imply to me that there has been a problem for others

    ........Orda
    Last edited by Orda Khan; 06-04-2007 at 23:44.

  4. #4
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Beta 8...A problem??

    Hello Jochi,

    ZoneAlarm can be odd indeed. It suffices right now (for me) to just disable it. But in the past I was often forced to deinstall it completely.

    Here's a zip version.
    http://www.mizus.com/files/files/MTW...Wars-beta8.zip
    Ja mata

    TosaInu

  5. #5
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Puzz3D
    Well I don't see how the problem can be the beta 8 because it only installed to one of your three MTW/VI installs. When was the last time you hosted an MTW/VI game? Maybe something else has changed in the interim.
    Nothing at all has changed or been installed except the beta 8 since last hosting VI

    Quote Originally Posted by Puzz3D
    I've been told that the Zone Alarm firewall stops the hosting of MTW/VI games even if you turn the firewall off.
    That is untrue. Did you not read my explanation of how I have always hosted games with no problems with Zone Alarm on my PC just set to Medium in the Firewall section.

    It is only since installing beta 8 that this problem has arisen.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  6. #6
    warning- plot loss in progress Senior Member barocca's Avatar
    Join Date
    Dec 2000
    Location
    (*disclaimer* - reality may or may not exist, in some societies reality is a crime, punishable by life)
    Posts
    5,341

    Default Re: Beta 8...A problem??

    i have to agree with Puzz,

    installing beta 8 to One copy of VI will not and can not have an impact on the other copies.
    files do Not get installed outside the VI directory tree.

    something else is causing the problems, a firewall or anti-spy-ware program blocking the port,
    or even malware hijacking the port

    You may not even know it is there, drive-by malware is becomming more and more common, i had a run in with some myself.
    The nastiest stuff like to make use of XP's "superhidden" feature to tuck itself away in plain site...
    The winds that blows -
    ask them, which leaf on the tree
    will be next to go.

  7. #7
    warning- plot loss in progress Senior Member barocca's Avatar
    Join Date
    Dec 2000
    Location
    (*disclaimer* - reality may or may not exist, in some societies reality is a crime, punishable by life)
    Posts
    5,341

    Default Re: Beta 8...A problem??

    FOR EXAMPLE
    if you have seen a popup like this

    then it is quite possible you have malware on your sytem



    B.
    The winds that blows -
    ask them, which leaf on the tree
    will be next to go.

  8. #8
    warning- plot loss in progress Senior Member barocca's Avatar
    Join Date
    Dec 2000
    Location
    (*disclaimer* - reality may or may not exist, in some societies reality is a crime, punishable by life)
    Posts
    5,341

    Default Re: Beta 8...A problem??

    if you see ads like that one open TASKMANAGER
    and kill ALL instances of explorer immediately from taskmanager

    anything you do, click the red-x, hit cancel, close from the taskbar,
    anything, will start the install process.
    kill ALL instances of explorer immediately from taskmanager

    B.
    The winds that blows -
    ask them, which leaf on the tree
    will be next to go.

  9. #9
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    1. Please answer Orda's question if there is no problem.

    2. Who discovered the LAN work around and why if there is no problem.


    We enjoyed playing Samurai Wars (the 20Nov version) so,

    if this cannot be resolved you have lost four potential players for this game.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  10. #10
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Hello Tosa,

    Quote Originally Posted by TosaInu
    Hello Jochi,

    ZoneAlarm can be odd indeed. It suffices right now (for me) to just disable it. But in the past I was often forced to deinstall it completely.
    I have never had any problems with Zone Alarm.

    Quote Originally Posted by TosaInu
    Is there anything different about this version compared with the one I downloaded from Yuuki's Signature?
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  11. #11
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Beta 8...A problem??

    Hello Jochi Khan,

    Had it a few times with STW, maybe some versions. Red Orchestra had a problem with ZoneAlarm too (only a year ago). A complete uninstall was the only solution.

    The one in Puzz3D's signature is the exe installer. I unpacked that and just zipped the mod files, ran another virusscan and uploaded that. When you unzip you'll get a folder called modfiles. Just copy the content of that to a VI install. So, same version.
    Ja mata

    TosaInu

  12. #12
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    hello Tosa,

    Thank you for your help.

    I will uninstall the Beta 8 game, make a new clean VI install and then copy the content of the modfiles to it.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  13. #13
    Senior Member Senior Member Tomisama's Avatar
    Join Date
    Nov 2000
    Location
    Illinois
    Posts
    2,835

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Jochi Khan
    1. Please answer Orda's question if there is no problem.

    2. Who discovered the LAN work around and why if there is no problem.


    We enjoyed playing Samurai Wars (the 20Nov version) so,

    if this cannot be resolved you have lost four potential players for this game.
    I first heard of the LAN work around years ago, and having nothing to do with Samurai Wars. I was only reminded of it recently when having a problem hosting a SW game, but it is not new.

    I believe it is like the problem caused by playing a single player game and then trying to play multiplayer without rebooting, or loosing sync with the host's game when you do not have strictserver imployed. That is, it is a short comming of the game, and not having to do with anyones mod.
    Last edited by Tomisama; 06-05-2007 at 12:36.
    HONOUR IS VICTORY - GO WITH HONOUR - KEEP THE CODE

    http://steamcommunity.com/profiles/76561198003816474

  14. #14

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Jochi Khan
    I will uninstall the Beta 8 game, make a new clean VI install and then copy the content of the modfiles to it.
    Delete all the maps in \Battle\Maps before unzipping beta 8. Also, if you use the unzip built into Windows, unzip beta 8 to a temp folder because it will create an extra subfolder above the files being unzipped. Then copy and paste the files under that subfolder to your MTW/VI install.

    The zip version of beta 8 is not going to fix the hosting problem. Something else is causing your hosted games to be invisible because even your unmodified MTW/VI doesn't work.
    Last edited by Puzz3D; 06-05-2007 at 17:47.

    _________Designed to match Original STW gameplay.


    Beta 8 + Beta 8.1 patch + New Maps + Sound add-on + Castles 2

  15. #15

    Default Re: Beta 8...A problem??

    Well I've read all the posts. I don't even have Z/A and I can't host either. My PC is brand new so either I'm the unluckiest guy in the world to pick up the same malware as a bunch of other guys or there is definitely something up with this mod

    ........Orda

  16. #16
    Nur-ad-Din Forum Administrator TosaInu's Avatar
    Join Date
    Jul 2002
    Posts
    12,326

    Default Re: Beta 8...A problem??

    Hello Orda Khan,

    The game MTW has some features. You recall mismatch in projectile stats when you played campaign first and then MP? Tomisama says that this lan thing was an issue years ago, this mod didn't even exist back then.

    It's software, the weirdest things happen. Maybe there is a part in MTW that locks another part (MP hosting module) as a side-effect?

    I wouldn't iron out the firewall. ZoneAlarm is not the only program that can block ports and when a port is blocked, hosting is not possible. Just configuring a firewall (if that is the problem) doesn't need to solve the problem. Even disabling from startup doesn't do the trick at times. In those cases the firewall has to be removed and all traces of it.

    Then there also is the delay in popping up. When I host (either MTW or a mod), it can take up to a minute before the game shows up.

    Have you tried the lan reset?

    Apart from the firewall, is there a router?

    If you have a clean install of MTW VI, try hosting there and install the mod after success?

    My current install is made using the same installer, I'm not aware of having done anything special, I can join and host.
    Ja mata

    TosaInu

  17. #17

    Default Re: Beta 8...A problem??

    Tosa
    As you know I used to run on ME and the only problem I ever encountered on MTW or VI was that I needed a restart before going MP or I'd crash to a black screen with green dots along the top ( I recall you were aware of/had seen the situation)
    I am on Vista now with a brand new PC and I read posts about Z/A and malware and I have more than doubts. I think it is a little bit more than pure coincidence that at least four seperate players are experiencing problems. Don't you think it a bit strange?
    The attitude has been very blunt; it's not the mod it's you or your PC. Poor Warman can't even get the thing to install.
    I played a 1v1 of this mod and it was just like going back a few years. I thoroughly enjoyed it and I would probably drag my weary carcasss onto my trusty steed again to experience those bygone days but with the terrible downward trend in TW MP, I've not played for so long that I am having trouble even remembering what MP play was.
    I believe you play on Sundays. That's fine I could join you but unfortunately I can't choose for myself and neither can I host and neither can other players but yet the mod is OK and there are other problems on different OS's and different machines?
    Well I made an effort but there you go. Pity the Warlords Beta was made because I could host Samwars

    .......Orda

  18. #18

    Default Re: Beta 8...A problem??

    I don't see how the Sam Wars mod could be affecting hosted game visibility. All the mod does is change graphics and stats. It doesn't change any system files, and it doesn't change the main executable which is what contains the network code. At worst, people can't join your hosted game due to a stat conflict or missing map.

    Quite often many players cannot see mtw/vi hosted games until they relog. That is they have to relog after the game has been hosted, and then they can see it. That's a known problem in mtw/vi.

    Another issue is that mtw/vi multiplayer doesn't work with some of the new video cards. Eventually, new hardware will completely kill mtw/vi multiplayer.

    You could also get software conflicts as well that prevent mtw/vi from working properly. I'm unclear about how much time elapsed between the last successful hosting of an mtw/vi battle and the installation of beta 8. If any other programs were installed between those two times, it could cause problems.

    Warman's computer can't run the installer which is a Visual Basic program. It's possible his Visual Basic run time library is out of date. In any case, Tosa made the zip install which can be used to bypass the Visual Basic installer, and that should work for him.

    _________Designed to match Original STW gameplay.


    Beta 8 + Beta 8.1 patch + New Maps + Sound add-on + Castles 2

  19. #19
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Puzz3D
    I'm unclear about how much time elapsed between the last successful hosting of an mtw/vi battle and the installation of beta 8. If any other programs were installed between those two times, it could cause problems.
    Approximately two weeks and no new programs have been installed before or after beta 8.
    Yes I do have a new ISP, but that account was set up on the 4th Dec 2006, Broadband ADSL 8MB, so you can rule out the 'different ISP' arguement.

    Repeating myself, I do not have any problems with hosting M2TW and on a regular basis. It is only with MTW/VI and only since I have installed the Beta 8
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  20. #20
    Clan Takiyama Senior Member R'as al Ghul's Avatar
    Join Date
    Jan 2003
    Location
    ignores routers who aren't elite
    Posts
    2,554

    Default Re: Beta 8...A problem??

    Jochi Khan,

    are you running Windows Vista?

    R'as

    Singleplayer: Download beta_8
    Multiplayer: Download beta_5.All.in.1
    I'll build a mountain of corpses - Ogami Itto, Lone Wolf & Cub
    Sometimes standing up for your friends means killing a whole lot of people - Sin City, by Frank Miller

  21. #21
    Clan Takiyama Senior Member R'as al Ghul's Avatar
    Join Date
    Jan 2003
    Location
    ignores routers who aren't elite
    Posts
    2,554

    Default Re: Beta 8...A problem??

    Hey everybody,

    I can sense some latent aggravation in this thread. I understand that the problem can be frustrating but let's remember that we're all friends here, even clanmates, and we all want the same: play the game.

    The new installer we're using is a python script my brother did for us. We need it because it would be too tedious to instruct everybody to clean out the map folders, etc. So far, we had more than 800 downloads in April alone. Tosa, CBR, Yuuki, barocca and I have not experienced any problems with the installation or the use of the mod. We don' have any word from the masses but no news is most probably good news in this respect.

    Quote Originally Posted by Orda Khan
    I am on Vista now with a brand new PC and I read posts about Z/A and malware and I have more than doubts. I think it is a little bit more than pure coincidence that at least four seperate players are experiencing problems. Don't you think it a bit strange?
    The attitude has been very blunt; it's not the mod it's you or your PC. Poor Warman can't even get the thing to install.
    .......Orda
    Orda,
    Tomisama has the problem that he cannot even start the game on Vista. It's most probably because of his graphics driver. I don't have experience with Vista but I noticed a lot of threads here and at .net about compatibility problems with Vista. One could try to run the game in a compatibility mode, maybe that helps. Apart from that I can't offer any support for Vista users. If all of the four mentioned players run Vista it can well be that you all suffer from the same problem.
    Concerning the "blunt" attitude I think you may've misinterpreted the one or other post. Keep in mind that communication is difficult in a text-based medium. Warman has had problems with all the mod releases, iirc. And the fact is that we run the mod without problems on XP.
    Also, the mod doesn't do much that other mods don't. We only change graphics and stats, the network code in the .exe is the same, no mod touches that. The installer also doesn't change any Windows files.

    At the moment I'd blame it on Vista. If Jochi runs XP and we can't sort it out I still wouldn't be convincend that it's the installer because I don't see how it could cause such problems.

    Please tell me if the four players mentioned by you are running XP or Vista.



    R'as

    Singleplayer: Download beta_8
    Multiplayer: Download beta_5.All.in.1
    I'll build a mountain of corpses - Ogami Itto, Lone Wolf & Cub
    Sometimes standing up for your friends means killing a whole lot of people - Sin City, by Frank Miller

  22. #22

    Default Re: Beta 8...A problem??

    Just for the sake of adding to cases reported and in hope that any problems will be resolved, i will say that i run the mod and play it in SP and online as a participant and host for the past 2 months without any problems on Windows XP.

    Many Thanks

    Noir

  23. #23

    Default Re: Beta 8...A problem??

    R'as,
    Yes I am on Vista and I am the only one. I answered Tomi's query about running VI on Vista, as I understand it to be an eight series Nvidia card problem. My GPU is 7600GT and this mod runs perfectly well in all ways except hosting.
    No news from 800 players may well be good news, it may also mean there are 800 SP players enjoying Japanese campaigns. How many actually play online?

    I seem to remember a bugged installer with a previous beta on SamWars

    .....Orda

  24. #24
    Clan Takiyama Senior Member R'as al Ghul's Avatar
    Join Date
    Jan 2003
    Location
    ignores routers who aren't elite
    Posts
    2,554

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Orda Khan
    R'as,
    Yes I am on Vista and I am the only one. I answered Tomi's query about running VI on Vista, as I understand it to be an eight series Nvidia card problem. My GPU is 7600GT and this mod runs perfectly well in all ways except hosting.
    I was afraid you'd say that. Ok, this is serious then. 3 or more players on XP who can't host.

    Quote Originally Posted by Orda Khan
    No news from 800 players may well be good news, it may also mean there are 800 SP players enjoying Japanese campaigns. How many actually play online?
    Okay, you've a point there. Most do play SP.

    We have to find out what you lot do differently or what's the difference between yours and our XP.
    To be absolutely sure that it's the mod we'd need to know if you can host games in MTW/VI with the current setup. Don't know how much time you have but it would be best to uninstall the mod and to try MP with a vanilla version. If that works, make a copy of the working version and install beta_8 over it, then try again.
    I agree that it's tedious but I've no idea how else to get more information on the situation.
    I'd also like to know if Jochi has made progress with Tosa's zip version.

    R'as

    Singleplayer: Download beta_8
    Multiplayer: Download beta_5.All.in.1
    I'll build a mountain of corpses - Ogami Itto, Lone Wolf & Cub
    Sometimes standing up for your friends means killing a whole lot of people - Sin City, by Frank Miller

  25. #25
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Hi R'as

    Quote Originally Posted by R'as
    I was afraid you'd say that. Ok, this is serious then. 3 or more players on XP who can't host.
    My graphics card is the same version as Ordas, The GeForce XFX 7600GT and as Orda said, we can play the mod with no problems, the only difference being, I am using XP and Orda has Vista. CBR hosted some games for us and they all played ok. So there is no problem with our setups, we can play the mod.

    Quote Originally Posted by R'as
    Okay, you've a point there. Most do play SP.
    This is what I was thinking. Highest number I have seen in foyer is 21 (and not all of them on Beta 8) so not many MP'ers amongst the 800.
    I have downloaded it 3 times incase of a 'bad' download causing the problem. Trying to rule out all possible options.

    Quote Originally Posted by R'as
    Don't know how much time you have but it would be best to uninstall the mod and to try MP with a vanilla version. If that works, make a copy of the working version and install beta_8 over it, then try again.
    I agree that it's tedious but I've no idea how else to get more information on the situation.
    I had 2 VI installs, Samurai Wars installed and the other with other mods installed. I did a new fresh install for the Samurai Warlords Beta 8. The reason is, I like to keep these games I enjoy on their own install and not have multiple mod installs on one. Hope you understand what I am saying.

    As it is now........ I have Samurai Wars installed and MTW/VI with other mods installed.
    The MTW/VI/Beta 8 I have uninstalled.

    Quote Originally Posted by R'as
    I'd also like to know if Jochi has made progress with Tosa's zip version.
    Tosa and I run some tests the other night with me trying to host. I could host but Tosa couldn't see my game. We both kept relogging and waiting for a few minutes in the hope it would work but no luck.

    I will try your suggestion of installing a new MTW/VI vanilla and check if I can host successfully with that. Will post the result.

    To recap in answer to some of the above posts.....

    1. Yes I do have a new ISP but that was December last year and I have hosted since then
    2. I was on adsl broadband 1MB connection before changing but now on 8MB connection.
    3. I can and still do host in M2TW with no problems. So can see no reason why MTW/VI Beta 8 should be a problem. It is the same PC with the same connection.
    4 After installing Beta 8 on this PC I was unable to host any of the MTW/VI installs.

    Barocca posted that files do not get installed outside the directory and affect others but it seems to have on this occasion. (I am not doubting your word Barocca :o))
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  26. #26
    Banned ELITEofWARMANGINGERYBREADMEN88's Avatar
    Join Date
    Sep 2006
    Location
    Castle 2_5_2, Swissland.
    Posts
    0
    Blog Entries
    3

    Default Re: Beta 8...A problem??

    Quote Originally Posted by barocca
    if you see ads like that one open TASKMANAGER
    and kill ALL instances of explorer immediately from taskmanager

    anything you do, click the red-x, hit cancel, close from the taskbar,
    anything, will start the install process.
    kill ALL instances of explorer immediately from taskmanager

    B.

    What you mean? Like the stuff under SYSTEM and that?


    Well if so, to late for me since I didn't know what to end task out of extacly

  27. #27

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Jochi Khan
    3. I can and still do host in M2TW with no problems. So can see no reason why MTW/VI Beta 8 should be a problem. It is the same PC with the same connection.
    M2TW communicates over a different port than does MTW. The port is a number that's included in each data packet, and it's used to direct incoming packets to the appropriate program. Firewalls block data packets that originate a request from outside the firewall unless the firewall has been configured to pass the included port number. As I recall, MTW uses port 18321 and MTW/VI uses port 18322, and these ports have to be open for both UDP and TCP. GameSpy also requires about 10 additional ports to be opened, but I don't know if they affect visibility of hosted games. I don't know what port or ports M2TW uses or if it requires both UDP and TCP. So, it's possible that a firewall could block MTW/VI hosting and not M2TW hosting, and that would be consistent with all the MTW/VI installs not working.

    Quote Originally Posted by Jochi Khan
    4 After installing Beta 8 on this PC I was unable to host any of the MTW/VI installs.[/B]
    But, two weeks elapsed between the last successful hosting of MTW/VI and the inability to host. Something could have changed in those two weeks.

    I run WinXP Pro + SP2, and have 6 installs of MTW/VI. I installed beta 8 to two of them; one for SP which I modify and one for MP which I don't change. I can host by enabling DMZ on my hardware router which forwards all ports to the local LAN ipaddress of my machine. I have Windows firewall running, but don't have to turn that off to host.

    Right now we only have 6 people playing Samurai Wars MP regularly. We all have MSN and can arrange games over that, and CBR hosts a teamspeak server on Sunday for those who have a headset and microphone. I think just about everyone can host, so it's not actually necessary to be able to host during this session. The network operation of this mod seems stable now. We get together on Sundays at around 19:00 gmt. We play for at least 3 hours, but last Sunday the session lasted 6 hours. AggonyKalle joined us for a couple of games. Unfortunately, RageFury can't get MTW/VI MP to work due to his new ATI X700 video card.
    Last edited by Puzz3D; 06-08-2007 at 05:04.

    _________Designed to match Original STW gameplay.


    Beta 8 + Beta 8.1 patch + New Maps + Sound add-on + Castles 2

  28. #28
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Puzz3D
    M2TW communicates over a different port than does MTW. The port is a number that's included in each data packet, and it's used to direct incoming packets to the appropriate program. Firewalls block data packets that originate a request from outside the firewall unless the firewall has been configured to pass the included port number. As I recall, MTW uses port 18321 and MTW/VI uses port 18322, and these ports have to be open for both UDP and TCP. GameSpy also requires about 10 additional ports to be opened, but I don't know if they affect visibility of hosted games. I don't know what port or ports M2TW uses or if it requires both UDP and TCP. So, it's possible that a firewall could block MTW/VI hosting and not M2TW hosting, and that would be consistent with all the MTW/VI installs working.
    So, why have I not had a problem hosting before? All I have ever had to do with my firewalls is set them to 'Allow' or 'Not block' the servers that I am connecting to.

    Quote Originally Posted by Puzz3D
    Right now we only have 6 people playing Samurai Wars MP regularly. We all have MSN and can arrange games over that, and CBR hosts a teamspeak server on Sunday for those who have a headset and microphone. I think just about everyone can host, so it's not actually necessary to be able to host during this session.
    No, but it would be necessary for one of us to be able to host at other times that suit us.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

  29. #29

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Jochi Khan
    So, why have I not had a problem hosting before? All I have ever had to do with my firewalls is set them to 'Allow' or 'Not block' the servers that I am connecting to.
    Is Windows Firewall turned on and Windows Automatic Updates enabled? If so, maybe an automatic update changed the Windows Firewall configuration. I have Windows Firewall turned on, but Windows Automatic Updates turned off. If you go to Control Panel then Security Center, you'll see if it's turned on. Access the Windows Firewall under Manage Security Settings, and check under the Exceptions tab to see if Medieval_TW is checked as an exception. There is also a check box there to display a message when Windows Firewall blocks a program. In Windows Firewall, you can't allow or block servers. You allow ports or programs.

    I don't know anything about Zone Alarm, but if it has an automatic update feature, the configuration could have changed or the program could have become incompatible with MTW/VI. We'd have to hear from someone who can host and is running the same version of Zone Alarm on the same version of Windows to rule out incompatibility.

    _________Designed to match Original STW gameplay.


    Beta 8 + Beta 8.1 patch + New Maps + Sound add-on + Castles 2

  30. #30
    ..fears no adversary Senior Member Jochi Khan's Avatar
    Join Date
    May 2002
    Location
    South Wales UK
    Posts
    1,213

    Default Re: Beta 8...A problem??

    Quote Originally Posted by Jochi Khan
    All I have ever had to do with my firewalls is set them to 'Allow' or 'Not block' the servers that I am connecting to.
    That should have read.. Programs ...and not Servers.

    I am aware of how windows XP sets the Exceptions. Have been using it for a number of years now. Checked and double checked, all the programs I need 'not blocked' are not blocked (all the necessary boxes are ticked). The windows updates do not change your Exceptions.

    Zone Alarm works differently in as much as you set your levels of security each time you want to play online. This you then change when you log off the games. Again, do not get changed when Zone Alarm does auto update.
    R.I.P Great Warrior Ja mata TosaInu


    sat at the..Nomad Alliance..campfire



    Do your best and do it according to your own inner standard
    --call it conscience--
    not just according to society's knowledge and judgement of your deeds.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO